Fwd: Job submission to Lonestar on TACC

From: Ali Emileh (ali.emileh_at_gmail.com)
Date: Thu Mar 05 2009 - 13:13:38 CST

Peter,

Thanks for the tips.
You are right about the user portal explicitly stating BSUB as the job
running program.

In the email they said "... you have 'bsub' command line with all the
parameter setup for
your run. But it is not the way you submit batch jobs on Lonestar ..." "...
Please comment
out the 'bsub' line and put options with #BSUB syntax." It may suggest that
there is only
a syntax prefereance (passing options through #BSUB and not the command
line?) and
nothing more. As just a random guess, I thought it terminates the job
because I'm running
namd off someone else's directory. So now I'm submitting the one in the path
the module
command points to. It's on the queue now.

What I still can't understand is how I'm supposed to make use of the MODULE
command.
Even when I do put it in the script, it returns "Command not found"!!! while
I still can run it
in normal environment. I don't know how I'm supposed to use the module
system.

Ali

---------- Forwarded message ----------
From: Peter Freddolino <petefred_at_ks.uiuc.edu>
Date: Thu, Mar 5, 2009 at 3:15 AM
Subject: Re: namd-l: Job submission to Lonestar on TACC
To: Ali Emileh <ali.emileh_at_gmail.com>
Cc: namd-l_at_ks.uiuc.edu

Hi Ali,

could you be a bit more specific about what they said about using bsub?
The lonestar user guide is fairly clear about bsub being the correct way
to submit jobs. I have used the runbatch script on lonestar successfully
as recently as about 6 months ago, but haven't had time on lonestar lately.

You may wish to try starting an interactive run
(http://www.tacc.utexas.edu/services/userguides/lonestar/ under "Running
Code") and then executing the ibrun command that is found in the
runbatch script and seeing if you get the same result (and any
additional output).

Best,
Peter

Ali Emileh wrote:
> Hi everyone,
>
> I have been trying to run a job on Lonestar with no success yet. None of
> the module swap command
> that the NAMDWiki article asks to use or the touch .nosoft command
> works. I tried to use the runbatch
> command which I think is in another user's directory (the one pointed
> to, in NAMDWiki, tg455591).
> It does work but terminates without any warning or error, pretty early
> in the run , saying it was 'killed
> by a signal external to LSF'. Contacting the support staff @ Teragrid I
> was told that using BSUB cmmand is not the right
> way to submit jobs and you should use the modules. But loading the NAMD
> module only sets up
> env variables. I don't know what is the command that actually runs namd.
>
> Reading the Lonestar documents, it seems that "ibrun" is the command
> that uses the different #BSUB
> options to run jobs but I can't figure out how to connect these bits
> together. Has anyone tried to use
> Lonestar using the runbatch script there? Any guidance will be highly
> appreciated.
>
> Thank you,
> Ali

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:50:35 CST