Re: Error with Shape Based CG Model

From: Anton Arkhipov (anton_at_ks.uiuc.edu)
Date: Wed Aug 06 2008 - 11:39:38 CDT

Hi Anirban,

Have you loaded both PSF and PDB of your protein into the same
molecule in VMD before applying CG Builder? If not, that could be the
reason, although there might be something else going on.

You can send me the protein you are trying to coarse grain, and I'll
have a look. Send it off the list, please. Also, let me know exactly
what steps you are going through before this happens - what are you
loading in VMD, what are the parameters you are using in the CG
builder, etc.

Anton.

On 6 Aug 2008, at 05:04, Anirban Ghosh wrote:

>
> Hi All,
> I am trying to generate a Shape-based CG model of a protein with 456
> residues through CG Builder plug-in of VMD. I tried with the default
> parameters and 15 and 30 CG beads, twice. But I am getting the
> following
> error every time:
>
>
> atomsel: frame -1 out of range for molecule 1
> atomsel: frame -1 out of range for molecule 1
> while executing
> "$sel writepdb $outAllAtom"
> (procedure "::cgnetworking::writeAllAtomPdb" line 11)
> invoked from within
> "::cgnetworking::writeAllAtomPdb $outAllAtom $inMolId $a_nk "
> (procedure "::cgnetworking::toNetworkingCG" line 273)
> invoked from within
> "::cgnetworking::toNetworkingCG $statusProc $inMolId $cgResName
> $cgPrefix
> $outPDB $outAllAtom $outTop $outParm $numBeads $numSteps $epsInit
> $epsFinal..."
> (procedure "::cgnetworking::networkCGMolecule" line 14)
> invoked from within
> "::cgnetworking::networkCGMolecule ::cggui::addStatusLine
> $::cggui::currentToCGMol $::cggui::toCGshapeResName
> $::cggui::toCGshapeNamePrefix $::cggu..."
> (procedure "::cggui::buildShapeCGExecute" line 119)
> invoked from within
> "::cggui::buildShapeCGExecute"
> invoked from within
> ".cggui.toCGShapeFrame.applyDB invoke"
> ("uplevel" body line 1)
> invoked from within
> "uplevel #0 [list $w invoke]"
> (procedure "tk::ButtonUp" line 24)
> invoked from within
> "tk::ButtonUp .cggui.toCGShapeFrame.applyDB
> "
> (command bound to event)
>
>
> How should I rectify this? Please suggest.
>
>
> Regards,
>
>
> --
> Anirban Ghosh
> Grade Based Engineer
> SECG, Bioinformatics
> C-DAC, Pune
> India
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:49:43 CST