
University of Illinois at Urbana-Champaign
Theoretical and Computational Biophysics Group
Summer School 2004 - University of Western Australia, Perth

Determining Force Fields

Rommie Amaro

Brijeet Dhaliwal

Zaida Luthey-Schulten

August 17, 2004.



CONTENTS 2

Contents

1 Biological Background and Chemical Mechanism 4

2 The CHARMM22 Force Field 6

3 HisH System Setup 7

4 The CHARMM22 Force Field 14

5 Missing Parameter Development 14

6 Semi-empirical parameter generation using SPARTAN 25

7 Minimization with new parameters 33



CONTENTS 3

Introduction

Molecular dynamics (MD) simulations are a powerful scientific tool used to study
a wide variety of systems in atomic detail. From a standard protein simulation,
to the use of steered molecular dynamics (SMD), to modelling DNA-protein
interactions, there are many useful applications. With the advent of massively
parallel simulation code such as NAMD2, the limits of computational analysis
are being pushed even further.

Inevitably there comes a time in any molecular modelling scientist’s career
when the need to simulate an entirely new molecule or ligand is necessary.
Therefore the technique of determining new force field parameters to describe
these novel system components becomes an invaluable skill. Determining the
correct system parameters to use in conjunction with the chosen force field is
only one important aspect of the process. Equivalently, the ability to use several
programs simultaneously to examine and refine the system in question is also a
critical element of these kinds of problems. However, it should be noted that the
extent of parameterization carried out in this exercise is minimal and designed to
emphasize the major points required in a more detailed fitting procedure. Road-
maps for more systematic optimizations that include experimental data can be
found in a series of articles for Charmm [1, 2], Amber [3], and other force fields,
including OPLS-AA [4, 5] and ECEPP. Additional sources for parameterization
can also be found on the web (see [6], [7], [8], [9]). Polarizable force fields that
include terms to allow polarization of the charge distribution by environment
are under development [10].

This tutorial will walk you through a comprehensive example of how one
investigates, sets up, and simulates a small nonstandard ligand bound to a
protein system; specifically, we will investigate the glutaminase subunit of the
hisH-hisF system and will determine parameters for the nonstandard residue.

Starting from the crystal structure in the protein database, and using the
breadth of available biochemical information, we will dock the small ligand
(glutamine) to the active site of hisH and develop the missing parameters in
accordance with the Charmm22 force field. As a first guess for the parameters,
we will try to derive as many of the missing parameters as possible from ex-
isting similar molecules already parameterized in the force field. Then we will
further refine these new parameters with semi-empirical quantum chemistry cal-
culations. Once the new parameters are finalized, we will minimize the system.
The combination of all of these techniques will require the use of at least four
different computational biology and chemistry packages.

The entire tutorial takes about 3 hours to complete.
This tutorial assumes that MOE [11], Spartan [12], VMD [13], NAMD [14]

and other software has been correctly installed on your computer. Go to the
forcefield tutorial directory by typing:

> cd tbss/forcefield
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1 Biological Background and Chemical Mecha-
nism

Living organisms have developed features to ensure their existence in a wide va-
riety of environments on Earth. While details of these features may be unique
to particular conditions or species, two minimum requirements are the ability
to reproduce and carry out regulated metabolic processes. A common theme
in metabolic processes is the synthesis of complex and diverse molecules from a
limited number of precursors. Amino acids are not only the building blocks of
proteins and peptides, they are also important precursors in the biosynthesis of
purines, pyrimidines, and other biomolecules. Additionally, amino acid biosyn-
thesis is an ancient and fundamental process, and these metabolic pathways are
represented in a diversity of organisms spanning all three domains of life.

Regulated production of histidine depends on the complex interplay between
nine catalytic active sites located on 6-8 polypeptide chains, depending on the
organism. High resolution crystal structures of several of the enzymes regulat-
ing this vital pathway are now available [15, 16]. Of particular interest is the
fifth step of the metabolic pathway, where a protein complex known as hisH-
hisF forms a key branch point. At this step, the formation of two products is
catalyzed by the heterodimeric enzyme complex, imidazole glycerol phosphate
synthase (IGPS), which consists of hisH, a class-I glutamine amidotransferase,
and hisF, a synthase subunit that catalyzes a cyclase reaction. One product,
imidazole glycerol phosphate (ImGP), is further used in histidine biosynthesis,
and the other, 5-aminoimidazole-4-carboxamide ribotide (AICAR), initiates de
novo synthesis of purines (see [17, 18] and references therein).

Characteristic of the superfamily to which it belongs, hisH has a strictly
conserved catalytic triad active site: CYS84, HIS178, GLU180. The cysteine
covalently binds glutamine, and the histidine, initially protonated, donates a
proton to the amide group of glutamine to produce ammonia and glutamate.
The conserved chemical mechanism for another enzyme (Carbamoyl Phosphate
Synthetase) belonging to this superfamily is depicted below [19]. Subsequent
steps allow the release of glutamate and the reprotonation of the active site his-
tidine (HIS178). The molecule of ammonia then diffuses roughly 10 angstroms
across the interface of the two proteins, enters the alpha-beta barrel of hisF
through a presently unknown mechanism, and is transported through the barrel
of hisF to the active site located at the C-terminal end of the barrel where it is
incorporated into the next substrate.

This exercise will lead you through the modelling of the hisH protein. We
will investigate the catalytic triad that comprises its active site and determine
the correct protonation states of all functionally important residues. After the
cysteine has covalently bound glutamine, we are presented with a non-standard
amino acid to simulate. It is our task to develop a set of force field parameters
for the novel residue for use in MD simulations.
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Figure 1: HisH mechanism for glutaminase reaction; we will model the system
after step 2 of this mechanism (middle, right).
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2 The CHARMM22 Force Field

The form of the potential energy function we will use in this exercise is taken
directly from CHARMM22 and given by the following equation [1]:

V =
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2 +
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kθ (θ − θ0)
2 +

∑
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kφ [1 + cos (nφ− δ)]
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]

+
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εrij
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The first term in the energy function accounts for the bond stretches where kb is
the bond force constant and b−b0 is the distance from equilibrium that the atom
has moved. The second term in the equation accounts for the bond angles where
kθ is the angle force constant and θ − θ0 is the angle from equilibrium between
3 bonded atoms. The third term is for the dihedrals (a.k.a. torsion angles)
where kφ is the dihedral force constant, n is the multiplicity of the function, φ
is the dihedral angle and δ is the phase shift. The fourth term accounts for the
impropers, that is out of plane bending, where kω is the force constant and ω−ω0

is the out of plane angle. The Urey-Bradley component (cross-term accounting
for angle bending using 1,3 nonbonded interactions) comprises the fifth term,
where kU is the respective force constant and U is the distance between the
1,3 atoms in the harmonic potential. Nonbonded interactions between pairs of
atoms (i, j) are represented by the last two terms. By definition, the nonbonded
forces are only applied to atom pairs separated by at least three bonds. The
van Der Waals (VDW) energy is calculated with a standard 12-6 Lennard-Jones
potential and the electrostatic energy with a Coulombic potential.

Questions Sketch the individual Charmm22 potential energy terms.
What is the difference between bonded and nonbonded interactions
and what are the energy terms corresponding to them? What terms
are likely to dominate the potential? What are the typical barrier
heights?



3 HISH SYSTEM SETUP 7

3 HisH System Setup

Exercise 1: Using VMD to investigate the hisH active site

To get an introduction to the system, load in the structure HisHmoe start.pdb
into VMD. Select the ligand glutamine and the catalytic triad (Cys84, His178
and Glu180).

Question: Identify all residues forming the glutamine docking site
and describe the chemical properties of them. Using VDW, MSMS,
or Surf representation in VMD, investigate the solvent accessibility
of the glutamine docking site.

Although the glutamine can be attached in VMD, we will use MOE to make
the covalent bond and determine what force field parameters are missing.

Exercise 2: System setup in MOE

For the following three exercises, we will use the molecular modelling program
MOE (Molecular Operating Environment). Although the exercise makes ex-
clusive use of the widely-used CHARMM22 empirical force field, any of the
calculations may be repeated and applied to other available parameter sets (e.g
AMBER, OPLS-AA, etc.).

Part 1: Starting MOE

To run MOE, open an Xwindow box and type the following at the UNIX com-
mand prompt: /usr/local/moe/bin/moe

A window entitled moe will appear. The following exercises will be conducted
from the main moe window.

Part 2: Loading the protein

We will begin by loading the PDB structure HisHmoe start.pdb into MOE.

1. In the top Main menu of MOE, click on File → Open. A new window
called Open will appear.

2. In the Open window, make sure the program is in the tbss directory. Select
HisHmoe start.pdb and click on OK. Another window entitled Load PDB
File will appear.

3. Within the Load PDB File window, look under New Objects and select
Center.

4. Click OK. The molecule will now appear in MOE.
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Figure 2: This is what your hisH system should look like in MOE.

In MOE we will be working out of the main moe window and the Sequence
Editor. The main moe window contains pull-down menus at the top of the
window and buttons for major function groupings on the top right-hand side of
the window. Often there are multiple ways a particular feature of the program
can be accessed. For example, you can open the Sequence Editor with the
buttons on the right or by selecting it under the Window top pulldown menu.
The Sequence Editor is a very powerful tool to select residues, hide them or
render them in different representations.

Figure 3: Sequence Editor window
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Part 3: Changing the representation of an object

In the Sequence Editor, click with the left mouse button on the ligand GLN to
select it. After it is selected, right mouse click on it. A popup menu will appear.
To make the selection:

1. Select Atoms → Select. The atoms will turn pink.

2. Right-click on GLN again.

3. Select Render → Ball and Stick.

Now glutamine should be rendered differently than the rest of the residues. Click
in the Main window in the open space and the pink arrowheads will disappear
(indicating the ligand is deselected).

Figure 4: The ligand highlighted within the molecule.

You should see something similar to the screen image in Fig. 4.

Questions: Now try changing the protein representation to back-
bone on your own. (Click with the left mouse button on chain 1
(protein chain) for selecting it, open the pop-up menu (right mouse
button) and choose Backbone: Cartoon.)

Part 4: Highlighting CYS84, HIS178 and the ligand

Let’s focus in on the catalytic triad to make our work easier. First, we will hide
the protein:

1. Click on Chain 1 to select the entire protein chain.

2. Right-click on Chain 1.
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3. In the popup menu select Atoms → Select.

4. Again, right-click on Chain 1. Then, select Atoms →Hide.

5. Click on the main moe window. Now only the ligand is shown

Figure 5: Only the ligand dislayed.

With VMD, you have already determined the residues of the catalytic triad as
well as the residues that comprise the docking site for the glutamine ligand.
You can access the residue CYS84 rapidly in the Sequence Editor by clicking
on it with the left mouse button. The residue will highlight in the Sequence
Editor and clicking with the right mouse button shows you the various options
you may apply to the selection.

1. Left-click on CYS84.

2. Right-click on CYS84. Select Atoms → Show.

3. Again, right click on CYS84 and select Render → Ball and Stick. Now
you should only see CYS84 and the ligand.

4. Repeat with HSD178 (histadine).

Figure 6: The ligand, CYS84 and HSD178 are dislayed.

For selecting atoms by element, hybridization or other chemical properties the
Selection pull-down menu is more suitable and you will see examples for using
it. With the Render pull-down you can do the same as you have experienced
with the pop menus. Play around with different selections and rendering modes
to get a feel for the program.
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Part 5: Adding missing hydrogens

Question: Does the x-ray structure have hydrogens? Why or why
not?

To add the hydrogens:

1. Go back to the main moe window.

2. In the top menu, click on Edit → Add Hydrogens.

It is important to remember that MOE adds hydrogens by guessing and does
not intrinsically know anything about protonation states of the various amino
acids. For example, histidine residues can be in a charged or neutral state
depending on the local environment within the protein. This property is very
often exploited by enzymes in order to carry out biochemical reactions (e.g.
as in our example of the catalytic triad of hisH). Since it is important from
a functional perspective, when we are building our model we must ensure the
model takes the relevant biochemical information into account.

Question: Study the chemical mechanism for the glutaminase re-
action catalyzed presented before. Compare the protonation states
of the catalytic residues generated by MOE to those in the mech-
anism. Make sure you have exactly the same protonation states as
after step 2 of the chemical mechanism (see Fig. 1.

When performing a full system preparation, it is important to check the proto-
nation state of every residue in the protein. However for this particular exercise
we will restrict ourselves only to the docking site in hisH.

Exercise 3: Connecting the ligand to the protein: MOE

Now we want to make the covalent bond between glutamine and the CYS84
residue of hisH.

Part 1: Labelling molecules in the structure

To begin making the covalent bond betweein glutamine and the CYS84 residue
of hisH, we need to determine where they are located. To do this:

1. Go to the main moe window in order to access the right column menu.

2. Click on Label → Name.
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You will now see the labels of all the molecules in the structure. You may have
difficulty deciphering the labels at this point. To get a better view, you can
use the rotate, scale and translation buttons on the bottom of the main moe
window.

Part 2: Creating the Bond

Now we will build the bond between the sulfur and carbon:

1. In the main moe window, click on the Builder button in the top right-hand
side menu. A window named Builder will appear.

2. In the main moe window, click on the atom labelled SG.

3. To select the second atom, press SHIFT on the keyboard, and click on
CDG

4. Go to the Builder window and click on the Bond button at the bottom of
the window.

5. A new MOE box will appear. Click Yes to Reparent atoms into one chain?

Figure 7: Highlighted SG and CDG molecules

We want to model the system after step 2 of the mechanism (see Figure 1). To
do this, we need to delete some atoms. We need to delete the atom NH2 and
its hydrogens (doing this will ”hydrolize” the ammonia away!). To delete:

1. In the main moe window, click on atom NH2

2. Now in Builder, click Delete.
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3. In the new Delete Atoms box, click OK. The attached hydrogens will also
be deleted.

4. Finally, select all hydrogens and delete them by go to the top pull-down
menu and clicking on Selection → Elements → Hydrogen in the top menu
of the main moe window.

Figure 8: Removed hydrogens.

Part 3: Saving the Structure

We will add the hydrogens back later with another program.

To save your structure:

1. In the top menu of the main moe window go to File → Save as.

2. In the file browser window, provide a file name and select the format to
be PDB.

3. Now we need to close the session by selecting File → Close.

In case you have problems making this file, we have provided you with the
structure HisHmoe cyg.pdb.
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4 The CHARMM22 Force Field

The form of the potential energy function we will use in this exercise is taken
directly from CHARMM22 and given by the following equation [1]:
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The first term in the energy function accounts for the bond stretches where kb is
the bond force constant and b−b0 is the distance from equilibrium that the atom
has moved. The second term in the equation accounts for the bond angles where
kθ is the angle force constant and θ − θ0 is the angle from equilibrium between
3 bonded atoms. The third term is for the dihedrals (a.k.a. torsion angles)
where kφ is the dihedral force constant, n is the multiplicity of the function, φ
is the dihedral angle and δ is the phase shift. The fourth term accounts for the
impropers (i.e. out of plane bending), where kω is the force constant and ω−ω0

is the out of plane angle. The Urey-Bradley component (cross-term accounting
for angle bending using 1,3 nonbonded interactions) comprises the fifth term,
where kU is the respective force constant and U is the distance between the
1,3 atoms in the harmonic potential. Nonbonded interactions between pairs of
atoms (i, j) are represented by the last two terms. By definition, the nonbonded
forces are only applied to atom pairs separated by at least three bonds. The
VDW energy is calculated with a standard 12-6 Lennard-Jones potential and
the electrostatic energy with a Coulombic potential.

Question: Sketch the individual Charmm22 potential energy terms.
What is the difference between bonded and nonbonded interactions
and what are the energy terms corresponding to them? What terms
are likely to dominate the potential? What are the typical barrier
heights?

5 Missing Parameter Development

We now have a nonstandard amino acid side group attached to the hisH protein.
As is very often the case with nonstandard groups, this residue does not have a
full set of parameters describing it.When presented with a nonstandard group,
the first task is to determine exactly which parameters are already known, and
which will need to be developed from scratch. In this case, only the atoms
forming the connection between the ligand glutamine and CYS84 are likely to
contain unknown parameters, as this connection is special to the reaction mech-
anism of hisH.
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In order to assign initial values to the missing Charmm22 parameters, we will
use the program MOE. These values will be checked and redefined using semi-
empirical calculations will be performed with the quantum chemistry package
Spartan. Finally we will incorporate the newly created parameters into a preex-
isting Charmm22 parameter file so that we can perform a minimization of hisH
with NAMD2.

When developing the new parameters for this nonstandard residue, we will ne-
glect any solvent effects and consider the molecule to be in the gas phase. The
glutamine-cysteine linkage is defined as a new residue in the Charmm22 topol-
ogy file with the name CYG. We will parameterize a truncated form of CYG
in order to simulate step III. The truncated CYG has the following formula:
CH3-S-CO-CH3 and its IUPAC name is methyl thioethanoate.

An Introduction to the Charmm22 Topology File

Below is the final topology file entry for the CYG residue. This exercise will
show you how to develop the values appearing in it.

RESI CYG 0.00
GROUP
ATOM N NH1 -0.47 ! |
ATOM HN H 0.31 ! HN-N
ATOM CA CT1 0.07 ! | HB1
ATOM HA HB 0.09 ! | |
GROUP ! HA-CA--CB--SG
ATOM CB CT2 -0.11 ! | | |
ATOM HB1 HA 0.09 ! | HB2 |
ATOM HB2 HA 0.09 ! O=C |
ATOM SG S -0.07 ! | \
!ATOM HG1 HS 0.16 ! \
GROUP ! \
ATOM CDG CC 0.55 ! \
ATOM OE1 O -0.55 ! \
GROUP ! HN2G \
ATOM CGG CT2 -0.18 ! | \
ATOM HG1G HA 0.09 ! HN1G-NG HB1G HG1G\
ATOM HG2G HA 0.09 ! | | | \
GROUP ! HAG-CAG--CBG--CGG--CDG=OE1
ATOM CBG CT2 -0.18 ! | | |
ATOM HB1G HA 0.09 ! | HB2G HG2G
ATOM HB2G HA 0.09 ! O1G=CG
GROUP ! |
ATOM CG CD 0.75 ! O2G-HO2G
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ATOM O1G OB -0.55
ATOM O2G OH1 -0.61
ATOM HO2G H 0.44
ATOM CAG CT1 -0.12
ATOM HAG HB 0.09
ATOM NG NH3 -0.62
ATOM HN1G HC 0.31
ATOM HN2G HC 0.31
GROUP
ATOM C C 0.51
ATOM O O -0.51
BOND CB CA SG CB N HN N CA
BOND C CA C +N CA HA CB HB1
BOND CB HB2
BOND SG CDG CDG CGG CGG HG1G CGG HG2G
BOND CGG CBG CBG HB1G CBG HB2G
BOND CBG CAG CAG HAG CAG NG CAG CG
BOND NG HN1G NG HN2G CG O2G O2G HO2G
DOUBLE O C CDG OE1 CG O1G
IMPR N -C CA HN C CA +N O
IMPR CDG OE1 SG CGG CG O1G O2G CAG
DONOR HN N
DONOR HN2G NG HN1G NG HO2G O2G
ACCEPTOR O C OE1G CDG O1G CG O2G CG NG CAG

Note the following features in the Charmm22 topology file:

• In the second column you can find the atom name of each individual atom.
The connectivity of the atoms is depicted in the drawing.

• In the third column the atom type is designated for each atom. The
parameter files of force fields do not have chemical properties for individual
atoms of the system. Instead, they have parameters for atom types in
order to minimize the number of entries in the file. It is assumed that
the chemical properties of i.e. every carbonyl group are the same and
are independent from the individual atom properties. From this column
the force field extracts the information for assigning the right parameters
during the simulation. If you want to distinguish two chemical functional
groups from each other you have to give them different atom types in the
force field. Assigning only different atom names is not sufficient.

Question: Find the two carbonyl groups in CYG. Will the bond
stretching, angle bending and torsional terms be the same for both
functional groups?
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• The fourth column shows the partial charge of each atom. There are var-
ious quantum mechanical methods available for assigning partial charges
in force fields. We will calculate partial charges from the electrostatic
potential (ESP charges). The atoms are grouped in sets, which the net
charge of each set is zero. This allows simulations of large residues when
an electrostatic cutoff is applied as every group is a separate entity.

• On the bottom you can find Bond and Improper (IMPR) entries. These
entries define the connectivity and the planarity of residues. Angles are
autogenerated in Charmm22.

An Introduction to the Charmm22 Parameter File

Below is an excerpt from a Charmm22 parameter file that shows some required
parameters necessary for a minimization run. The force field below contains the
final missing heavy atom parameters for CYG and can be used as a reference
for the assessment of the parameters you develop in the next few exercises.
Due to time constraints, for the following exercises, we will only perform semi-
empirical calculations. The final parameter set was developed using a higher
level of theory (an ab initio Hartree-Fock calculation with the 6-31G** basis
set). Therefore the final parameter values presented below may differ slightly
than the ones you determine.

Question: Why does an ab initio calculation for the truncated form
of CYG so take so much longer compared to pentane (both systems
have the same number of heavy atoms)?

BONDS
!
!V(bond) = Kb(b - b0)**2
!
!Kb: kcal/mole/A**2
!b0: A
!
!atom type Kb b0
! Modified for CYG residue after 6-31G** geometry optimization Felix
S CC 240.000 1.7814 ! ALLOW ALI SUL ION

ANGLES
!
!V(angle) = Ktheta(Theta - Theta0)**2
!
!V(Urey-Bradley) = Kub(S - S0)**2
!
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!Ktheta: kcal/mole/rad**2
!Theta0: degrees
!Kub: kcal/mole/A**2 (Urey-Bradley)
!S0: A
!
!atom types Ktheta Theta0 Kub S0
!

! Modified for CYG residue after 6-31G** geometry optimization
CT2 S CC 34.000 100.2000 ! ALLOW ALI SUL ION

CT2 CC S 50.000 114.5000 ! ALLOW ALI SUL ION

O CC S 75.000 122.2000 ! ALLOW ALI SUL ION

Note the following features in the Charmm22 parameter file:

• It contains all numerical values required for Charmm22 energy functions
explained in section 2 of this tutorial. The forcefield contains entries
for bonds, angles, dihedrals, impropers and nonbonded interactions. The
forcefield also contains comments describing where these values have been
obtained either by experimental spectroscopic measurements or quantum
mechanical calculations.

• The bond and angle entries contain the value for the force constant in
the first column in the physical units of kcal/mole/Å. The second column
contains equilibrium bond or angle distance in Å or degrees, respectively.

• The next section contains the torsion angles comprised of dihedrals and
impropers. The individual values will be explained in the course of the
exercise and you will perform a dihedral drive of the torsion CT3-S-CC-
CT3.

The values for the nonbonded interactions are the standard VDW parameters
in Charmm22 required for the Lennard-Jones potential of your atom types.

Assigning Initial Values for Unknown Parameters with MOE

We will begin parameterizing CYG in this exercise. First you have to build the
truncated CYG residue. MOE will use pattern recognition on the Charmm22
force field and the atom types to assign initial values to any unknown parame-
ters. Afterwards, we will set up a minimization run with our newly developed
parameters and calculate one dihedral rotational barrier in the truncated CYG.

Part 1: Building CYG

MOE has pre-defined templates for many functional groups. Here, we are going
to build a chain of C-S-CO-C (hydrogens will be added automatically).
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In the Builder window:

1. Open the Builder in the right column.

2. Click on C

3. Now to add the next atom, click on the very end of one of the hydrogens.
When you click with the left mouse button on a hydrogen, a pink mark
will appear indicating that it is selected.

4. Click on S

5. Repeat this sequence with the three other atoms, making sure to select a
hydrogen on the previous group is selected before adding a new group

6. Click on Close to exit the builder and deselect all atoms by clicking on
empty space in the main moe window.

7. Change the rendering style to ball and stick by clicking on Render → Ball
and Stick.

Figure 9: C-S-CO-C molecule

Experiment with different rendering styles. An example of ball and stick is
shown in Figure 4.

Part 2: Specifying the Force Field

Now it is time to specify the force field and options we want to use for our
calculations. As mentioned previously, we will perform our calculations in gas
phase, that is no explicit or implicit solvation models. The dielectric constant
used for electrostatic interactions will be set to one with no distance-dependency.

1. Go to the main moe window, top pull-down menu.
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2. Select Compute → Mechanics → Potential Control and click on Apply.

Figure 10: What your potential setup box should look like.

Make sure that the loaded force field is charmm22.ff and that all the other
options are set to the ones specified in Fig. 10. Afterwards, click Close.

Part 3: Labelling Atoms

Next, display the atom types and partial charges of the atoms.

1. In the right column of the main moe window, select Label→ MM Type

2. Return to the right column and choose Label→ Charge

You will notice a charge of zero on each atom because we have not loaded in
the Charmm22 force field yet. The atom types are displayed together with
the partial charges. Note that the atom types for the terminal methyl groups
(CT3) are different from the oxygen bound carbon atom (C). They correspond
to carbon atoms that are electronically different. Note also that all hydrogen
atoms have the same atom type (HA). All the hydrogens are electronically
equivalent, since all are bonded to sp3 carbons.

Part 4: Assigning Partial Charges

The partial charges of all the atoms need to be ”assigned.” In order to do this,
click on:
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1. Go to the top pull-down menu and selectCompute → Partial Charges.

2. In the new window:

• Select Apply to: All atoms

• Select Method: Current Forcefield

• Do not select the Adjust Box

3. Click on OK.

The charges are now defined according to the Charmm22 force field for the
corresponding atoms. Note that all equivalent hydrogens have the same charge,
and that the total charge of CYG sums to zero as expected.

Part 5: Viewing / Printing Parameter Reports

You can look at the parameters for the truncated CYG molecule by:

1. Go to the top pull-down menu in the main moe window.

2. Then, click on Compute → Mechanics → Parameter Report

A new window will appear entitled ”Forcefield Parameter Report.” By default,
the parameters for ”Atom Type” are displayed first. You can look at all the
parameters by selecting them individually from the drop-down menu next to
”Parameters.” Several examples, Fig. 11, 12, 13, 14 are shown here. (Additional
descriptions of the force field can be found under the HELP menu in the main
window.) If you like, you can click on ”Text Edit” at the bottom of the window;
this will bring up a new window with all the parameters displayed in one text
file. From there, you can save it to an ASCII text file if you like.

Question: Parameters are given by atoms types. What parameters
should we be calculating with a quantum chemistry calculation?

A Closer Look at Dihedral Parameters

Note the dihedral (torsional) parameters. The analytical form of a dihedral
term in the CHARMM force field:

Vφ = kφ [1 + (cos (nφ− δ))] (3)

where φ is the value of the dihedral angle, kφ is the force constant, n is the
symmetry of the rotor (e.g. 3 for methyl groups) and δ is the phase. MOE
follows this analytical form, but lists the parameters in a different format: The
first four numbers are the atom numbers in the molecule. The four atom types
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Figure 11: The Forcefield Parameter Report detailing the ”Atom type” param-
eters.

Figure 12: The Forcefield Parameter Report detailing the ”Bond Stretch” pa-
rameters.

are the atom types for which a torsional term is defined and will be calculated.
Then follow five numerical values. These values correspond to the kφ constant
of the analytical form given above. Each of the five terms correspond to n =
1 to 5 in the analytical function given above, i.e., up to five values of n can
be used simultaneously, each with a different force constant. The n = 1 term,
with a positive C1 constant, has a single minimum at 180 degrees or the trans
conformation. A negative value of C1 will create a maximum at 180 degrees,
and therefore create a minimum at the cis conformation. The n = 2 term, with
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Figure 13: The Forcefield Parameter Report detailing the ”Angle Bend” param-
eters.

Figure 14: The Forcefield Parameter Report detailing the ”Torsion” parameters.

a positive C2 value, creates minima at 90 and 270 degrees. A negative C2 value
creates minima at 0 and 180 degrees, which is useful for enforcing planarity.
The n = 3 term, with a positive C3, creates maxima at 0, 120 and 240 degrees,
which will emphasize the staggered conformation of sp3 carbons. A negative C3

will emphasize the eclipsed conformation.
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For instance, the line:

9 8 5 1 HA CT2 CT2 CT3 0.000 0.000 0.195 0.000 0.000

could also be written, for these four atoms:

Vφ = 0.195 · [1 + cos (3φ)] (4)

Since we only have a force constant for n=3, the value of the force constant is
0.195, and the phase is zero (d = 0 since we have +0.195 and not 0.195). A
sample Matlab plot of this function is presented below. In standard CHARMM
notation, the exact same information would be written as follows:

HA CT2 CT2 CT3 3 0.195 0

i.e., the four atom types, the symmetry of the rotor (n), the force constant
(kθ) and the phase (d). Be sure to save your generated CYG molecule for later
reference:

1. Go to the top pull-down menu in the main moe window.

2. Select File→ Save as→ File format PDB.

Figure 15: Matlab plot of Eq. (3) presented above.

Now that we have completed the exercises in MOE, close the program by clicking
on File → Quit in the top pull-down menu.
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6 Semi-empirical parameter generation using SPAR-
TAN

In this exercise, we’ll be using the quantum chemistry software package Spartan
to calculate the force field parameters for CYG.

Part 1: Starting Spartan

To start Spartan:

1. On your Macintosh Desktop Dock go to Finder → Applications

2. In the Applications directory, double click on the Spartan icon.

Part 2: Building a new molecule

Get ready to build a new molecule in Spartan by choosing:

1. File → New

Figure 16: The Spartan Program

You should see the Model Kit interface. You can build molecules by selecting
atom (and bond) types at the right, and placing them by clicking on the left
portion of the screen. Atoms can be connected by clicking on the open valences.
Start by building CYG, CH3 − S− CO− CH3. All the bonds are single except
for the double bond between the carbon and oxygen. If you make a mistake,
you can easily fix it by selecting Edit → Undo.
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Tip:. In Spartan, you can use the middle mouse button to rotate
the molecule, the right mouse button to translate the molecule, and
shift+right button to scale the molecule.

You can turn on atom labels by choosing Model: Labels. You should have
something like Fig. 17.

Figure 17: Building CYG in Spartan

Tip:. If you made mistakes in the structure, you can fix them by
choosing Expert mode at the right and selecting the atoms or bonds
to alter.

Close the Model Kit menu by clicking on the red button in the top left corner.
Then minimize the structure by selecting Build → Minimize from the menu.
Once it’s done, you should see:

Figure 18: CYG after minimization in Spartan

Everything is ready now for a semiempirical quantum mechanics calculation.
You optimize the geometry of the structure, calculate electrostatic potential
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(ESP) charges and vibrational frequencies. Finally you will perform a coordinate
drive (a.k.a. an energy profile) for determining the rotation barrier of one of
the dihedral angles.

Part 3: Geometry Optimization and Vibrational Modes

From the main menu, choose Setup → Calculations and set the following op-
tions:

• Equilibrium Geometry at Ground State

• Model: Semi-Empirical PM3

• Subject to: Symmetry

• Compute: Frequencies, Electrostatic Charges

• Print: Atomic Charges

• Options: check Converge

It should look identical to Fig. 19.

Figure 19: Setting up the energy calculation.

You can submit the job and view its output by choosing:

1. Click on Setup → Submit Choose a name for the job save the job files to
the directory you’re working in.

2. The job will take a couple of moments to complete. A window will appear
indicating the completion of the job

3. Then go to Display→ Output
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The output file lists details about the method used, and lists the Cartesian
coordinates of the atoms. You can measure atomic distances and bond angles
by using the Geometry pulldown.

Questions: What is the final energy of the CYG system? How many
cycles has Spartan performed to converge? Measure the bonds,
angles and dihedrals of the missing parameters in the report and
compare the values with the proposed values from MOE.

Now, we are going to display the vibrational modes. The modes can be viewed
through the animation part of the program. Click: Display → Vibrations; when
you check the boxes you can watch individual vibrational modes. Be sure to
increase the amplitude to see the vibrations clearly.

Figure 20: Vibrations Window

Question: Look at the measured angles and bond lengths and
compare them to experimental values for other thioester linkages
found in the PDB database (for general thioester linkage informa-
tion, see [20]). See thioester linkage for 1ODV.pdb, figure presented
below.

A systematic calculation of the force constants for the bond stretching and angle
bending motion can be obtained from the ab initio calculations [9], but is beyond
the scope of this exercise. To complete the exercise close the Vibrations window.
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Figure 21: Thioester linkage found in 1ODV.pdb, photoactive yellow protein.

Part 4: Atomic Charges

Next, we are going to display a surface around the atoms, on which we will
map the ESP charges of the molecule. First check out the numerical values of
Mulliken charges and ESP charges and compare the difference between them.

1. Select Model → Ball and Wire

2. Then, choose Model → Labels

3. Finally, select Model → Configure In the Configure window, select Mul-
liken first and later, Electrostatic Charges.

Generally you will see that the partial charge values derived from an ESP cal-
culation are higher than the Mulliken charges. ESP charges are calculated to
reproduce the electrostatic potential around an atom, whereas the Mulliken
charges are derived from the electron occupancy of orbitals. ESP charges are
usually more suitable for force field generation. You can display a potential
surface by:

1. Clicking on Setup → Surfaces.

2. In the new window, selectAdd.

3. Then in the new ”Add Surface” window, select Surface → density and
Property → potential and click OK.

4. Submit the surface calculation with Setup → Submit.

5. When the job completes, you can view the surface with Display → Sur-
faces. In the new ”Surfaces” window, you can toggle the surface on and
off by checking the box next to density.
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Figure 22: Surface of molecule with ESP charges

Questions: Does the color scheme on the surface fit the ESP partial
charges?

Be sure to toggle the surface off to proceed to the next part of the exercise.

Part 5: Coordinate driving energy profile

The next exercise will be to calculate the energy of rotation around the H1-C1-
S1-C2 dihedral. In Spartan, this is called an Energy Profile calculation (there
are other names for the same task, such as conformational sampling, coordinate
drive, or dihedral search). Change the labels back to the atom name so you are
sure you pick the correct atoms (Model → Configure → Labels). Now we will
have to define the dihedral angle of interest:

1. Go to Geometry → Measure Dihedral.

2. Select the four atoms of interest (H1-C1-S1-C2).
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Figure 23: Dihedral selection

In the bottom bar it lists the selected dihedral by atom, and also displays the
angle in degrees.

1. Select Display → Properties. A Molecule Properties window will appear.

2. Click on the small lock symbol in the lower right corner to constrain the
dihedral. You will notice that the Properties Window changes to display
Constraint Properties for the dihedral we are interested in.

3. Within the window, change the values to:

• Value: 0 To: 360

• Steps: 12

4. Now select: Setup → Calculations

5. Select Energy Profile at Ground state with Semi-empirical PM3, Subject
to: Symmetry, Print: Atomic Charges, check Converge. Then hit OK.

6. Select Setup → Submit.

Once the calculation is complete (it takes about one minute to run), you can
plot the Energy Profile. You may notice that now there are two copies of the
molecule in the main Spartan window. You need to select the new molecule, as
it now has all the different torsion angles loaded into a sequence of coordinate
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files named P1, P2, P3, ..., P13. Once you have selected the new molecule, we
can plot the Energy Profile by the following steps:

1. Select Display → Spreadsheet.

2. In the new window, click on Add.

3. In the ”Add Column” window, click on E and drag it over to the sec-
ond column in the spreadsheet window. Be sure the units of Energy are
kcal/mol.

4. In the main Spartan window, select Display → Plots. Keep the X axis set
to Molecule, and select the Y axis to be E (kcal/mol), then click OK.

Figure 24: Dihedral energy profile results.

Spartan automatically superimposes the plot of the energy profile on top of the
molecule. If you click on the ”play forward” button on the bottom bar in the
main window, you can watch the torsion angle change and simultaneously see
the corresponding point on the plot. See Fig. 24.

Question: What is the amplitude and periodicity of the dihedral
energy profile? Where are the minimum and maximum points of
the energy?
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7 Minimization with new parameters

In this unit, you’ll use our state of the art molecular dynamics program NAMD2
with the Charmm22 force field. You should have the following files in your di-
rectory:

Topology file: top all27 prfar cyg nh4.inp
Parameter file: par all27 prot na lipids full.inp
NAMD config file: HisHmini.namd
PDB file: name of your MOE generated PDB file: filename.pdb

The parameter file was generated with the same protocol used in the previous
section of this tutorial. However, rather than performing a semi-empirical calcu-
lation, the parameters in par all27 prot na lipids full.inp were calculated
by full ab-initio quantum mechanics using the 6-31G** basis set, a process that
takes several hours on a fast machine.

First we have to generate a NAMD2-compatible PDB file. You can generate
a clean PDB file using the VMD console. Load the PDB file HisHmoe docked.pdb
into VMD and run the following commands in the VMD console:

set sel [atomselect top "all"]
$sel set segname HISH
$sel writepdb HisHmoe cyg.pdb

Now open the VMD generated file HisHmoe cyg.pdb in a text editor and
change the name of residue 84 from CYS to CYG. Otherwise PSFGEN will not
recognize the correct topology for the residue.

We also must add hydrogens with the topology file using the program PSF-
GEN through VMD. In the topology file the connectivity and therefore also the
correct protonation state for each individual residue is defined. In contrast to
the hydrogen adding procedure in MOE, this allows us to specify exactly what
the protonation states of all the residues in the system should be.

Open a VMD tkcon window and start PSFGEN by running:

package require psfgen

Now, following steps you have been through in the NAMD2 tutorial, we
need to make a psfgen input file in order to create the .pdb and .psf files the
simulation requires. To do this, open a text editor (outside of VMD) and type
the following lines:

topology top all27 prfar cyg nh4.inp

segment HISH {
first NTER
last CTER
pdb HisHmoe cyg.pdb
}
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coordpdb HisHmoe cyg.pdb HISH

guesscoord

writepsf HisH gln.psf
writepdb HisH gln.pdb

When you have finished, save the file as buildHisH.pgn and be sure it is in
the same directory as all your working files (i.e. HisHmoe cyg.pdb and topology
top all27 prfar cyg nh4.inp).

Now, return to the VMD tkcon terminal. Typing the following commands
will start PSFGEN and make the PSF and PDB files we need:

psfgen < buildHisH.pgn > out

When you are finished you will have a PDB file containing all coordinates
including hydrogens, a PSF file containing all the information about connectiv-
ity, mass and charge of each individual atom in the structure, and a logfile of
the PSFGEN program’s activities in the file called out. Take a look at both
files with a text editor to get familiar with the format.

Question: Does the PSF file resemble the topology file?

Finally you will solvate the system for running a minimization in the NPT
ensemble with a timestep of 1 femtosecond, a uniform dielectric constant of 1
and periodic boundary conditions. The electrostatic interactions will calculated
with the Particle Mesh Ewald Method.

Start Solvate in the VMD console by running:

package require solvate
solvate HisH gln.psf HisH gln.pdb -t 9 -o HisH solv

Question: Examine HisH gln.pdb and your new solvated system file,
HisH solv.pdb. How many atoms does the file now contain before
and after solvation?
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You just created a rather large and well solvated globular protein system. For
the purposes of this tutorial, we have provided you with a less solvated (not
necessarily good!) system so that you can minimize it on the laptop we supply
you. The real solvated system has too many atoms to realistically minimize on
these machines. In the minData directory we have provided you is the smaller
system, HisHsolvate.pdb and HisHsolvate.psf. The namd2 config file we supply
you will work with these smaller systems.

Run the minimization on the solvated system using the configuration file
HisHminishort.namd. At the unix command prompt in a terminal shell, type:

namd2 HisHminishort.namd > HisHminishort.namd.out

Question: Open the NAMD2 config file HisHmini.namd
and briefly explain what each command does. The com-
mands are defined in the users guide available online at
http://www.ks.uiuc.edu/Research/namd/current/ug/. Look under
the Chapter on Basic Simulation Parameters and the NAMD con-
figuration parameters. What minimization method is being used?
What is temperature during the minimization run?

The output of your NAMD job can be found in HisHminishort.namd.out.
You can use namdplot to look at energy changes during the minimization. The
minimization job you just ran was for only 500 steps. Although these G4 laptops
are powerful, minimizing for 10,000 steps would require over 2 hours of compute
time! We have provided you with the full minimization run results for a much
longer run. All the minimization files are located in the directory minData
(to get there, type ”cd minData” at the command line). Use namdplot to
look at the energy changes over the longer minimization run we provide you
HisHmini.namd.out.

Load the DCD file in VMD and check the relevant distances between glu-
tamine and the catalytic triad. You can determine how much the structure has
changed during the minimization by using the RMSDscript.

Question: How much do they differ from the equilibrium values in
the force field and from the initial unminimized structure? Has the
structure converged during your minimization?
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