Will MPICH2 work for NAMD?

From: Lee Wei Yang (lwyang_at_ljbi.org)
Date: Mon Nov 09 2009 - 12:37:58 CST

Dear NAMD users,

We plan to use the 8 processors in a single machine with two Quadro-core Nehalem CPUs to run NAMD in parallel.
I assume we need to install MPI.
The user guide says " NAMD uses the system-provided MPI library (with a few exceptions) and standard
system tools such as mpirun are used to launch jobs. Since MPI libraries are very often incompatible
between versions, you will likely need to recompile NAMD and its underlying Charm++ libraries
to use these machines in parallel (the provided non-MPI binaries should still work for serial runs.)
The provided charmrun program for these platforms is only a script that attempts to translate
charmrun options into mpirun options, but due to the diversity of MPI libraries it often fails to
work."

Is it ok we install MPICH2?
After we compile the source codes, do we use ++local flag in the charmrun or not?

Any suggest helps. thanks.

Lee

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:51:40 CST