Re: missing libraries for NAMD 2.7 on Linux cluster?

From: Axel Kohlmeyer (akohlmey_at_gmail.com)
Date: Mon Nov 09 2009 - 07:32:15 CST

hi eric,

On Sat, Nov 7, 2009 at 2:09 AM, Erik Nordgren <c.e.nordgren_at_gmail.com> wrote:
> Hello folks,
>
> I use a Red Hat Linux 9, Xeon-based cluster with PBS job scheduling to
> run NAMD. I recently tried switching from NAMD 2.5 (which ran fine,
> using the standard Linux binary) to NAMD 2.7 (using the pre-compiled
> binary for "NAMD_2.7b1_Linux-x86") and unfortunately, the latter
> failed to run -- I see error messages like the following:
>
> /data/apps/NAMD_2.7b1_Linux-x86/namd2: /lib/tls/libc.so.6: version
> `GLIBC_2.3.4' not found (required by
> /data/apps/NAMD_2.7b1_Linux-x86/namd2)
> libdl.so.2 => /lib/libdl.so.2 (0x40028000)
> libm.so.6 => /lib/tls/libm.so.6 (0x4002b000)
> libstdc++.so.6 => not found
> libc.so.6 => /lib/tls/libc.so.6 (0x42000000)
> /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

this tells you that the operating system on your cluster is
older than the one the one the namd binary was compiled on.

in fact, redhat 9 is a horribly outdated; it was released over
six years ago. it also hints at the fact, that the machine you
try to run on, may be outdated as well and its performance
subpar to a modern desktop (perhaps in combination with
a couple of GPUs).

> I tried searching the forum archives here for help, and I got the idea
> that our cluster might be missing some needed C libraries, i.e., that
> the libraries we have don't match those with which the binary was
> compiled... does this seem like the basic problem? Can anyone suggest
> a way to try to fix this? I suppose trying to compile NAMD 2.7 from

you can follow the approach of projects like openoffice and supply
the matching libraries _and_ dynamic linker in a separate directory,
and reset LD_LIBRARY_PATH and launch the executables with

/path/to/new/ld-linux.so.2 namd2 input.conf

but chances are that your kernel may not support required system
calls, so it is not guaranteed to work.

> source on our cluster would be the next step, but since that might be
> nontrivial, I figured first I would ask here as to whether there is
> something simpler that I'm missing.

the simplest thing would be to hassle your sysadmins to do their job
and update the OS to a modern version. i am certain that there are
a ton of unfixed security issues with red hat 9. i ditched my last rh9
installation about four years ago and by that time it had already been
on some sort of volunteer legacy support.

cheers,
    axel.
>
> thanks,
> Erik
>
> --
> C. Erik Nordgren, Ph.D.
> Post-Doctoral Researcher
> Dept. of Chemistry
> University of Pennsylvania
>
>

-- 
Dr. Axel Kohlmeyer    akohlmey_at_gmail.com
Institute for Computational Molecular Science
College of Science and Technology
Temple University, Philadelphia PA, USA.

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:51:40 CST