Re: Regarding ABF Simulation

From: Jagan Mohan (o.jagan_at_gmail.com)
Date: Mon Sep 14 2009 - 23:58:03 CDT

Branko,

I am running ABF in NAMD 2.6. So I changed the following and ran it again.

"set ABFdir ./abf-1.8
source ./abf-1.8/abf.tcl"

with

"source ./abf-1.8/abf.tcl
package require abf"

but end up with the same error that is

FATAL ERROR: Setting parameter TclForces from script failed!

And i do have the abf folder in the current directory which has all the tcl
scripts. Please advice me further.

Thanks and Regards,
Jagan Mohan

On Tue, Sep 15, 2009 at 2:04 AM, Branko <bdrakuli_at_chem.bg.ac.yu> wrote:

> Jagan, if you ruining ABF in NAMD 2.7b1, you should make separate file for
> ABF input (see below) and add only
>
> Colvars on
> colvarsConfig name of colvar config. file (syntax given below)
>
> Likely that you run ABF at 2.6, so try to change
>
> "set ABFdir ./abf-1.8
> source ./abf-1.8/abf.tcl"
>
> with
>
> "source ./abf-1.8/abf.tcl
> package require abf"
>
> And check do you have really /abf-1.8/abf.tcl where you define in input.
>
> Hope this help.
>
>
>
>
> Colvar definition for distance between two group of atoms:
>
> colvarsTrajFrequency 1
> colvarsRestartFrequency 10000
> analysis on
>
>
> colvar {
>
> name d
>
> lowerBoundary number - minimal expected in Angstroms
> upperBoundary number -maximal expected in Angstroms
> width 0.01
>
> distance {
> group1 {
> atomnumbers atom niumber(s)
> }
> group2 {
> atomnumbers atom number(s)
> }
> }
> }
>
> abf {
> colvars d
> fullSamples 500
> hideJacobian no
> outputFreq 1000
> applyBias yes
> }
>
> _________________
>
> Jagan Mohan wrote:
>
> Hello Everyone,
> I am running an ABF Simulation with the distance parameter. When I start
> the job on 4 processors i get the following error.
>
>
> FATAL ERROR: Setting parameter TclForces from script failed!
>
>
> This are the lines in my input file
>
> # ABF SECTION
> set ABFdir ./abf-1.8
> source ./abf-1.8/abf.tcl
> # ORDER PARAMETER
> abf coordinate distance
> abf abf1 8846
> abf abf2 9876
> abf xiMin 5.0
> abf xiMax 34.0
> abf dxi 0.1
> # SAMPLING
> abf fullSamples 500
> abf dSmooth 0.1
> abf forceConst 10.0
> abf writeXiFreq 100
> # OUTPUT
> abf outFile full_run.abf
>
>
> Could anyone tell me what is wrong.
>
>
> Thanks and Regards,
> Jagan Mohan
>
> ------------------------------
>
>
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.409 / Virus Database: 270.13.95/2368 - Release Date: 09/13/09 17:50:00
>
>
>
>
>

-- 
-{[O]}-

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:51:28 CST