NAMD 2.7b1 on SGI Altix 330

From: David McGiven (davidmcgivenn_at_gmail.com)
Date: Thu Mar 26 2009 - 08:50:31 CDT

Dear NAMD Users,

I've downloaded the new NAMD 2.7b1 release for Altix (Linux-Itanium-
Altix) and tried it on a SGI Altix 330 machine with SLES and SGI
ProPack 4SP3.

Running namd2 produces the following error :

./namd2: error while loading shared libraries: libstdc++.so.6: cannot
open shared object file: No such file or directory

An ldd namd2 reports that libstdc++.so.6 is ceirtanly missing :

        linux-gate.so.1 => (0xa000000000000000)
        libmpi.so => /usr/lib/libmpi.so (0x2000000000058000)
        libdl.so.2 => /lib/libdl.so.2 (0x2000000003ad8000)
        libimf.so.6 => /usr/lib/sgi/libimf.so.6 (0x2000000003af0000)
        libm.so.6.1 => /lib/tls/libm.so.6.1 (0x2000000003d30000)
        libstdc++.so.6 => not found
        libc.so.6.1 => /lib/tls/libc.so.6.1 (0x2000000003de4000)
        libunwind.so.7 => /lib/libunwind.so.7 (0x2000000004010000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x200000000405c000)
        librt.so.1 => /lib/tls/librt.so.1 (0x2000000004094000)
        /lib/ld-linux-ia64.so.2 (0x2000000000000000)

NAMD 2.6 used to work fine and din't depend on libstdc++.so.6 library.

Is there any way I can make NAMD 2.7b1 work without having to upgrade
the OS of the Altix machine nor recompiling it from source ?

Thanks

Best Regards,
David McGiven

--
David McGiven
Associate Researcher
Universitat Autonoma de Barcelona
davidmcgivenn_at_gmail.com

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:50:40 CST