Re: compiling NAMD failed on windows with Cygwin

From: accomp lin (accomplin_at_yahoo.com.cn)
Date: Fri Jan 09 2009 - 22:06:37 CST

Dear Axel
 
Sorry for my delayed reply. I had got no time so i just compiled NAMD on Linux. Now I can start compiling it on windows again. I changed all "\" into "/" and the problem disappear. However, I got a new error, it says:
 
/usr/lib/gcc-lib/i686-pc-cygwin/3.3.3/../../../..i686-pc-cygwin/bin/ld: cannot find -ltcl8.3
collect2: ld returened 1 exit status
Fatal error by charmc in directory .....

I already downloaded window version of TCL and fixed the path to its files as NAMD release notes states. So what's the problem. Should I copy TCL libs into some directory of Cygwin manually? Thank you
 
Regards
 
Jiaqi
 
 

--- 08年12月29日,周一, Axel Kohlmeyer <akohlmey_at_cmm.chem.upenn.edu> 写道:

发件人: Axel Kohlmeyer <akohlmey_at_cmm.chem.upenn.edu>
主题: Re: namd-l: compiling NAMD failed on windows with Cygwin
收件人: "accomp lin" <accomplin_at_yahoo.com.cn>
抄送: namd-l_at_ks.uiuc.edu
日期: 2008,1229,周一,11:36下午

On Mon, 29 Dec 2008, accomp lin wrote:

J> Dear developer of NAMD:

dear jiaqi,

J> I'm compiling NAMD on windows with Cygwin. I tried several time but
failed. The problem is that i didn't set the directory of charm5.9, tcl,
fftw in .arch file correctly. After making this right, I finally got the NAMD
compling on progress. But I then I got the follows error:
J>  
J> -LE:\Mr.Lin\comp\NAMD_2.6_Source\tcl/lib -ltcl8.3 \
J> -LE:\Mr.Lin\comp\NAMD_2.6_Source\fftw/lib -lsrfftw
-lsfftw \
J> obj/dcdplugin.o  \
J> \
J> -lm -o namd2
J> E:Mr.LincomNAMD_2.6_Sourcecharm-5.9/net-Cygwin/bin/charmc: not found
J> make: *** [namd2] Error 127
J>  

J> I browsed to the .../net-Cygwin/bin/ directory but I found a charmc
J> link is actually there. So what's my problem? Is that becasue some
J> "\" is lacked in the command? Where can I find the command
so I can
J> add the "\" to it myself?
J>  
J> Please help

please read the cygwin documentation more carefully!
cygwin emulates a unix environment, so everything you
provide - for example path names - has to be giving
in "unix"-format and the unix path separator is the
forward slash '/'. the backward slash '\' is an escape
character in scripts and makefiles and as such indicates
to use the next character literally. because of that
your build script cannot find the charmc script, because
it is looking in the wrong location.

to produce a backslash you'd have to use '\\' (or
'\\\\'
in case the string is interpreted twice), but i recommend
to specify all paths with '/' to avoid this.

cheers,
   axel.

J> Thank you!
J>  
J>  
J> Jiaqi
J>  
J>  

      ___________________________________________________________
  ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ
http://card.mail.cn.yahoo.com/

-- 
=======================================================================
Axel Kohlmeyer   akohlmey_at_cmm.chem.upenn.edu   http://www.cmm.upenn.edu
   Center for Molecular Modeling   --   University of Pennsylvania
Department of Chemistry, 231 S.34th Street, Philadelphia, PA 19104-6323
tel: 1-215-898-1582,  fax: 1-215-573-6233,  office-tel: 1-215-898-5425
=======================================================================
If you make something idiot-proof, the universe creates a better idiot.
好玩贺卡等你发,邮箱贺卡全新上线!


      ___________________________________________________________ 
  好玩贺卡等你发,邮箱贺卡全新上线! 
http://card.mail.cn.yahoo.com/

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:50:21 CST