Re: srand in a tclforces script

From: Vlad Cojocaru (Vlad.Cojocaru_at_eml-r.villa-bosch.de)
Date: Thu Dec 11 2008 - 08:31:37 CST

Dear all,

Sorry .. mea culpa ... I had a wrong syntax for "srand" in my tcl script
and that's why namd was complaining ...
Now it works .. I get identical results in identical conditions ..

Greetings
vlad

Vlad Cojocaru wrote:
> Dear NAMD users,
>
> I have a tclforces script in which I need to intialize a random unit
> vector. I use the tcl "rand" function twice for that purpose (to
> generate the spherical coordinates theta and psi).
>
> However, If I run a simulation twice using the same "seed" parameter
> in the NAMD configuration file I still get different results between
> the 2 simulations.
>
> So, I thought to initialize the random number seed before the first
> "rand" call in my tcl script using the tcl "srand" function. However,
> NAMD complaints and I get an error saying that it is not possible to
> set srand in the tclforces script.
>
> Does anyone have any idea what could I do to have exactly the same
> results from 2 simulations using this tcl script that calls the "rand"
> function twice ?
>
> Thanks for any suggestion !!
>
> Best wishes
> vlad
>
>

-- 
----------------------------------------------------------------------------
Dr. Vlad Cojocaru
EML Research gGmbH
Schloss-Wolfsbrunnenweg 33
69118 Heidelberg
Tel: ++49-6221-533202
Fax: ++49-6221-533298
e-mail:Vlad.Cojocaru[at]eml-r.villa-bosch.de
http://projects.villa-bosch.de/mcm/people/cojocaru/
----------------------------------------------------------------------------
EML Research gGmbH
Amtgericht Mannheim / HRB 337446
Managing Partner: Dr. h.c. Klaus Tschira
Scientific and Managing Director: Prof. Dr.-Ing. Andreas Reuter
http://www.eml-r.org
----------------------------------------------------------------------------

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:50:15 CST