NAMD stops running without error messages or termination

From: Yinglong Miao (yimiao_at_indiana.edu)
Date: Mon Mar 03 2008 - 17:18:12 CST

Dear NAMD developers/users,

I come across a problem when calling the "calcforces" procedure in my
simulations. In the procedure I have all atom forces are loaded and thus
their accelerations are calculated to find the maximum and average atomic
acceleration. I use this procedure to characterize some structures generated
using mathematical methods (not through MD run) and there are cases with
large atomic forces. The problem is that every time after I had NAMD output
"nan nan nan" for force values, the program stopped running without giving
any error messages or leading to termination. Attached is my TCL script for
the procedure and the end of a typical simulation output would be as the
following:

..
TCL: Running for 0 steps
ENERGY: 3300 3788.8832 4786.6457 3087.4315
261.5842
-494383.4222 115179.6536 0.0000 0.0000
nan nan nan nan

TCL: Running for 0 steps
TCL: Warning: acceleration of atom 9419 (894.826882588) exceeding the limit!
TCL: Warning: acceleration of atom 9420 (595.230294045) exceeding the limit!
TCL: Warning: ft(11008) has nan values!

I intended to have the program exit the calcforces procedure to continue the
simulation once having such warning messages. But the program just stopped
running. It could be possible that NAMD has a bug for this very special
case. But can anyone take a look at it for me? Any suggestions will be
greatly appreciated.

Thanks,
Long

-- 
Yinglong Miao
Ph.D. Candidate
Center for Cell and Virus Theory
Chemistry Department, Indiana University
800 E Kirkwood Ave Room C203A, Bloomington, IN 47405
Tel: 1-812-856-0981

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:49:18 CST