Tests not running for Charm++ Myrinet with MPICH-MX

From: brmorgan_at_clarku.edu
Date: Wed Jan 23 2008 - 14:35:05 CST

Hi,

When I run the charm++ tests, simplearrayhello for example, I get the
error messages below.
The system is a 24-node AMD Opteron dual core cluster with Myrinet and
MPICH-MX.

The build options I used are:
./build mpi-linux-amd64 gcc --no-shared -O -DCMK_OPTIMIZE=1
For reasons regarding the mpi libraries, I have to use gcc.
I am using a modified conv-mach.sh, which I have attached, to designate
the location of the mpich libraries. The mpich directory listed in the
error output is not the directory where the correct libraries are located.

I read on the NAMD Wiki: NamdOnMyrinet that the latest version of charm++
supports the new MX and MPICH-MX libraries. I downloaded the latest
version, but it also does not list mx as a build option.

Any advice would be greatly appreciated.

Brittany Morgan

Errors:
simplearrayhello> ./charmrun ./hello

Running on 1 processors: ./hello
0 - MPI_INIT : MPIRUN chose the wrong device ch_p4; program needs device
ch_mx
/usr/local/mpich-1.2.6-pgi-k8-64-gige/bin/mpirun.ch_p4: line 243: 19900
Segmentation fault
/home/bmorgan/NAMD_2.6_Source/charm-5.9/mpi-linux-amd64-gcc/tests/charm++/simplearrayhello/./hello
-p4pg
/home/bmorgan/NAMD_2.6_Source/charm-5.9/mpi-linux-amd64-gcc/tests/charm++/simplearrayhello/PI19843
-p4wd
/home/bmorgan/NAMD_2.6_Source/charm-5.9/mpi-linux-amd64-gcc/tests/charm++/simplearrayhello


This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:49:12 CST