Re: Re: build charm++ and namd

From: Peter Freddolino (petefred_at_ks.uiuc.edu)
Date: Thu Jul 31 2008 - 07:38:31 CDT

Hi Vlad,
for nontrivial charm++ issues, you're more likely to have success with
the charm++ people (ppl_at_cs.uiuc.edu), most of whom don't read namd-l.
BTW, is there any particular reason you're compiling with -O3? charm++
isn't the sort of code that's likely to benefit from this, and since
charm++ is usually compiled at -O2, it's conceivable for you to run into
something that the higher optimization breaks (this isn't your problem
here, but I figured I'd note it).
Best,
Peter

Vlad Cojocaru wrote:
> Just to follow up on the previous email, it seems that during build a
> strange thing happen.
> The 2 lines below appear in my build.log file (just before the errors
> I posted in my previous mail):
>
> cat pup_f.f90.sh >pup_f.f90
> chmod a+x pup_f.f90
>
> This obviously makes no sense at it cats the sh script
> (src/util/pup_f.f90.sh) into the fortran file and that's why I got the
> reported errors (the fortran compiler tries to compile an .sh script).
> However, the build script does not contain these 2 lines so I dont
> know where they come from ... Even more strange is that yesterday I
> build charm++ 6.0 on another opteron machine without any problem with
> exactly the same build I use here...
>
> Vlad
>
> Vlad Cojocaru wrote:
>> Dear NAMD users,
>>
>> I have a problem building charm++ (version 6.0) and namd on a cluster
>> with AMD Barcelona chips using intel 10.1.015 compiler.
>> My build command is:
>> ./build charm++ net-linux-amd64 icc10amd tcp --no-build-shared
>> -DCMK_OPTIMIZE=1 -O3 2>&1 | tee build.log
>>
>> Although the build appeared successful (megatest passed), I got the
>> error attached during the build.
>>
>> Is this something I should worry about? Has anybody seen this before ?
>>
>> Thanks
>>
>> Best wishes
>> vlad
>>
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:48:07 CST