Re: charmrun simulations over macpros

From: pedro.borkowski_at_utoronto.ca
Date: Wed Jun 20 2007 - 20:44:42 CDT

Here are some more details on what i see happening when i run simulations.

Both of the macpros have gigabit ethernet.
Also correction about my previous post there are 2 processors in each
mac pro but there are and two cores per processor.

When i use namd to run simulations on one machine using the code:

./namd2 +p4 asd.conf > data.dat &

i notice that there is only one namd process id using around 360% of
the processors.

when i run namd thorugh charmrun over the two macpros

./charmrun +p8 namd2 asd.conf > data.dat &

i notice that there are 8 namd2 process ids in total each at around 66%.

but the overall performace is much faster on the single processor than
the two macpros together.

I also looked at the transfer rate of the ethernet which is about
35MB/s. So im wondering if it should be much faster to increase the
performance?

I also looked into charm++ but the website doesnot mention any support
for intel macs at the moment, so im wondering if charmrun has not been
optimized for the mac pros yet to fully take advantage of the 8 cores?

please send me your thoughts.

-Pedro

Quoting Cesar Luis Avila <cavila_at_fbqf.unt.edu.ar>:

> Indeed the bottleneck is using ethernet to interconnect the nodes. Is
> it fast or gigabit ethernet? Nevertheless I don't think a cat6 cable
> would improve that much your performance. You should consider upgrading
> your interconnection system to get better scaling. Nevertheless I don't
> know if upgrading to myrinet or infiniband worth the price for just two
> nodes.
> Ethernet has proved to be good enough for connecting up to 8 nodes. I
> think the problem you are facing is that 4 processors on each node are
> competing for use of just one network card. I don't know if namd would
> take advantage of having more than one network card on each node (say
> one for each CPU).
>
>
>
> pedro.borkowski_at_utoronto.ca escribió:
>> Hey all,
>>
>> I was able to set up two mac pros (4 cores each) to run some
>> simulations. I have gigabit Ethernet between connected through a
>> CAT5e crossover cable. I was able to run simulation on all 8 cores
>> but after some benchmarking, i found that a simulation in a single
>> machine (4 processors) is much faster that a simulation on the two
>> machines (8 processors). I looked more into it and i found that
>> when running the simulation, i am only using upto 66% of each
>> processor. I was wondering if there is any way to tell the
>> computers to allocate as much of the processors into the simulation
>> instead of just the 66%. I was also wondering if the ethernet is
>> the limiting factor into these simulations? If it is, would a cat6
>> crossover cable improve the performance of the simulation?
>> Also i tried to run a simulation where both computers were logged
>> off the accounts instead when some1 is logged on. The logging off
>> made the simulation a little faster.
>>
>> anyone have any ideas?
>>
>> Thanks
>> -Pedro
>>
>>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 15:46:31 CST