Re: NAMD 2.7b1 on SGI Altix 330

From: Axel Kohlmeyer (akohlmey_at_cmm.chem.upenn.edu)
Date: Thu Mar 26 2009 - 10:56:40 CDT

On Thu, 2009-03-26 at 14:50 +0100, David McGiven wrote:
> Dear NAMD Users,
>
> I've downloaded the new NAMD 2.7b1 release for Altix (Linux-Itanium-
> Altix) and tried it on a SGI Altix 330 machine with SLES and SGI
> ProPack 4SP3.
>
> Running namd2 produces the following error :
>
> ./namd2: error while loading shared libraries: libstdc++.so.6: cannot
> open shared object file: No such file or directory
>
> An ldd namd2 reports that libstdc++.so.6 is ceirtanly missing :
>
> linux-gate.so.1 => (0xa000000000000000)
> libmpi.so => /usr/lib/libmpi.so (0x2000000000058000)
> libdl.so.2 => /lib/libdl.so.2 (0x2000000003ad8000)
> libimf.so.6 => /usr/lib/sgi/libimf.so.6 (0x2000000003af0000)
> libm.so.6.1 => /lib/tls/libm.so.6.1 (0x2000000003d30000)
> libstdc++.so.6 => not found
> libc.so.6.1 => /lib/tls/libc.so.6.1 (0x2000000003de4000)
> libunwind.so.7 => /lib/libunwind.so.7 (0x2000000004010000)
> libpthread.so.0 => /lib/tls/libpthread.so.0 (0x200000000405c000)
> librt.so.1 => /lib/tls/librt.so.1 (0x2000000004094000)
> /lib/ld-linux-ia64.so.2 (0x2000000000000000)
>
> NAMD 2.6 used to work fine and din't depend on libstdc++.so.6 library.
>
> Is there any way I can make NAMD 2.7b1 work without having to upgrade
> the OS of the Altix machine nor recompiling it from source ?

yes, but i'd say it is worse than recompiling from source.

you have to collect all required runtime libs equivalent to the
runtime environment the binary was compiled on in a special directory,
also copy the matching ld-linux.so there. then rename the namd2
executable to namd2.real and generate a bourne shell script roughly
like this and call it namd2 instead:

#!/bin/sh
COMPATLIBDIR=/some/path/to/newer/libs
LD_LIBRARY_PATH=${COMPATLIBDIR}:${LD_LIBRARY_PATH-/lib}
export LD_LIBRARY_PATH
exec ${COMPATLIBDIR}/ld-linux.so /path/to/namd/namd2.real "$@"

this is effectively the same trick that openoffice uses and i've
used it in the past to make executables of vmd work on very old
linux installations. the unknown here is the compatibility of the
intel compiler runtime and the mpi library. those may turn out
not to be compatible (but they usually are).

cheers,
  axel.

>
> Thanks
>
> Best Regards,
> David McGiven
>
>
> --
> David McGiven
> Associate Researcher
> Universitat Autonoma de Barcelona
> davidmcgivenn_at_gmail.com
>
>

-- 
=======================================================================
Axel Kohlmeyer   akohlmey_at_cmm.chem.upenn.edu   http://www.cmm.upenn.edu
   Center for Molecular Modeling   --   University of Pennsylvania
Department of Chemistry, 231 S.34th Street, Philadelphia, PA 19104-6323
tel: 1-215-898-1582,  fax: 1-215-573-6233,  office-tel: 1-215-898-5425
=======================================================================
If you make something idiot-proof, the universe creates a better idiot.

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:21:51 CST