NAMD Linux LAM/MPI 7.1 execution error

From: Christophe Combet [PBIL/IBCP/CNRS] (c.combet_at_ibcp.fr)
Date: Tue Mar 07 2006 - 07:45:35 CST

Dear all,

I compiled a MPI (LAM/MPI 7.1.1) version of NAMD v2.6b1 under Linux RH
ES 3.0 in order to use it with PBSpro 7.1 (pbs_mpilam command).
I ran in to troubles when executing NAMD.
Is it something wrong with the command line or a compilation problem ?

Thanks for help.

EXEC:

lamboot
LAM 7.1.1/MPI 2 C++/ROMIO - Indiana University

./namd2 src/alanin

Info: Entering startup phase 8 with 8819 kB of memory in use.
Info: Finished startup with 9092 kB of memory in use.
Segmentation fault (core dumped)

mpirun -np 3 ./namd2 src/alanin

Info: Entering startup phase 8 with 8808 kB of memory in use.
Info: Finished startup with 8944 kB of memory in use.
------------------------------------------------------------------------
-----
One of the processes started by mpirun has exited with a nonzero exit
code. This typically indicates that the process finished in error.
If your process did not finish in error, be sure to include a "return
0" or "exit(0)" in your C code before exiting the application.

PID 1576 failed on node n0 (127.0.0.1) due to signal 11.
------------------------------------------------------------------------
-----

mpirun -np 3 ./charmrun ./namd2 src/alanin

Info: Entering startup phase 8 with 8820 kB of memory in use.
Info: Finished startup with 9092 kB of memory in use.
------------------------------------------------------------------------
-----
One of the processes started by mpirun has exited with a nonzero exit
code. This typically indicates that the process finished in error.
If your process did not finish in error, be sure to include a "return
0" or "exit(0)" in your C code before exiting the application.

PID 19442 failed on node n0 (127.0.0.1) due to signal 11.
------------------------------------------------------------------------
-----
------------------------------------------------------------------------
-----
It seems that [at least] one of the processes that was started with
mpirun did not invoke MPI_INIT before quitting (it is possible that
more than one process did not invoke MPI_INIT -- mpirun was only
notified of the first one, which was on node n0).

mpirun can *only* be used with MPI programs (i.e., programs that
invoke MPI_INIT and MPI_FINALIZE). You can use the "lamexec" program
to run non-MPI programs over the lambooted nodes.
------------------------------------------------------------------------
-----

./charmrun -np 3 ./namd2 src/alanin

Info: Entering startup phase 8 with 8820 kB of memory in use.
Info: Finished startup with 9092 kB of memory in use.
------------------------------------------------------------------------
-----
One of the processes started by mpirun has exited with a nonzero exit
code. This typically indicates that the process finished in error.
If your process did not finish in error, be sure to include a "return
0" or "exit(0)" in your C code before exiting the application.

PID 23166 failed on node n0 (127.0.0.1) due to signal 11.
------------------------------------------------------------------------
-----

COMPILE:

fftw 2.1.5
./configure --enable-float --enable-type-prefix --enable-static
--prefix={somewhere}
make
make install

tcl 8.3.5
./configure --disable-shared --prefix={somewhere}
make
make install

CHARM++
vi /charm-5.9/src/arch/mpi-linux/conv-mach.sh
./build charm++ mpi-linux --basedir /home/user/lam --no-shared
hello test is OK

NAMD
vi Make.charm
vi arch/Linux-i686.fftw
vi arch/Linux-i686.tcl
./config tcl fftw Linux-i686-MPI
cd Linux-i686-MPI
make

OS:

uname -a
Linux 2.4.21-37.ELsmp #1 SMP Wed Sep 7 13:28:55 EDT 2005 i686 i686 i386
GNU/Linux

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:19:17 CST