Re: namdplot: command not found

From: bo baker (bo.bybaker_at_gmail.com)
Date: Fri Oct 14 2005 - 14:04:53 CDT

Hello,

Thank you very much for being spend your time to help me. I have try
all your suggestions. Here are what I got:

mriv209-01:~] bo% cd desktop
[mriv209-01:~/desktop] bo% ./namdplot TEMP pbr1.log
tcsh: ./namdplot: Command not found.

Then I check 'ls -la' and ' head -30 namdplot'. Here are what I got:

[mriv209-01:~/desktop] bo% ls -la
total 28424
drwxr--r-- 24 bo staff 816 12 Oct 13:20 .
drwxrwxrwx 42 1703 244 1428 11 Oct 10:29 ..
-rwx------ 1 bo staff 21508 12 Oct 13:41 .DS_Store
-rw-r--r-- 1 bo staff 0 20 Jan 2004 .localized
-rw-r--r-- 1 bo staff 1707 25 Sep 14:41 3Ddock-091920
-rw-r--r-- 1 bo staff 1422 20 Sep 15:01 Amber-commands.txt
drwxrwxrwx 27 bo staff 918 19 Sep 13:13 Documents
drwxr-xr-x 22 bo staff 748 5 Sep 15:26 MD
-rw-r--r-- 1 bo staff 235142 18 Jun 2004 N62-model1-2.pdb
-rw-r--r-- 1 bo staff 235142 18 Jun 2004 N62.pdb
-rw-r--r-- 1 bo staff 235142 13 Dec 2004 N62.txt
drwxr-xr-x 16 bo staff 544 10 Oct 11:02 PBR
-rw-r--r-- 1 bo staff 1945 12 Oct 13:20 PBR-namd-101005.txt
drwxrwxrwx 21 bo staff 714 10 Oct 11:04 StAR
-rw-r--r-- 1 bo staff 1423 2 Sep 15:26 VMD-commands.txt
-rw-r--r-- 1 bo staff 17409 21 Sep 17:44 amber-092105
drwxr-xr-x 20 bo staff 680 29 Sep 2004
complete2.3_ppcDarwin7_acad_1-3alpha1
-rwxr-xr-x 1 bo staff 3534 11 Oct 16:34 namdplot
-rw-r--r-- 1 bo staff 8083 10 Oct 16:18 pbr-vmd-101005
-rw-r--r-- 1 bo staff 910436 11 Oct 00:40 pbr1.log
drwxr-xr-x 19 bo staff 646 13 Jul 17:04 pdbs
-rw-r--r-- 1 bo staff 8501 3 Oct 11:34 sander-082505
-rw-r--r-- 1 bo staff 2394 20 Sep 10:47 swiss-preference1
-rw-r--r-- 1 bo staff 12835375 29 Apr 13:47 vmd183.dmg
[mriv209-01:~/desktop] bo%
[mriv209-01:~/desktop] bo%
[mriv209-01:~/desktop] bo% head -30 namdplot
  echo "Usage: $0 [zero] [diff] [from <first>] [to <last>] [<yfield>
[<yfield> . echo "Usage: $0 [zero] [diff] [from <first>] [to <last>]
[<yfield> [<yfield> .[mriv209-01:~/desktop] bo% y $tmpfile &L" -pexec
"YAXIS TICKLABEL PREC 0" \

Then I search 'awk':

[mriv209-01:~/desktop] bo% which awk
/usr/bin/awk
[mriv209-01:~/desktop] bo% which gawk
gawk: Command not found.
[mriv209-01:~/desktop] bo% which nawk
nawk: Command not found.
[mriv209-01:~/desktop] bo%

Could you please help me to figure out what is wrong here with
'namdplot' command?

Your advice have been very appreciated.

Bo

On 10/13/05, Robert Brunner <rbrunner_at_uiuc.edu> wrote:
> From ~/desktop, try just running ./namdplot
>
> If that doesn't work, try running "ls -la" and send me the output.
> Also type "head -30 namdplot" and send me that.
>
> As I mentioned in a previous message, the tutorials are actually
> designed to be run on Macs, in particular, the PowerBooks the TCB
> group uses to host workshops. However, as is mentioned on:
> <http://www.ks.uiuc.edu/Training/Tutorials/>
>
> the tutorials assume that certain software (e.g. namdplot, xmgrace)
> is already installed. Human resources being limited, the training
> team has not had the opportunity to prepare installation instructions.
>
> Robert
>
> PS. I don't work on the tutorials, but I am (slightly) familiar with
> them and Mac OS X.
>
> On Oct 13, 2005, at 2:26 PM, bo baker wrote:
>
> > Hello,
> >
> > Thanks for your suggestions. But I am still stucked. The commands
> > didn't work. Here is how I did:
> >
> > [mriv209-01:~] bo% cd desktop
> > [mriv209-01:~/desktop] bo% chmod a+x namdplot
> > [mriv209-01:~/desktop] bo% /Users/bo/Desktop/namdplot TEMP pbr1.log
> > tcsh: /Users/bo/Desktop/namdplot: Command not found.
> >
> >
> > Then I try 'chmod 755':
> >
> > [mriv209-01:~/desktop] bo% chmod 755 namdplot
> > [mriv209-01:~/desktop] bo% /Users/bo/Desktop/namdplot TEMP pbr1.log
> > tcsh: /Users/bo/Desktop/namdplot: Command not found.
> >
> > The computer just can't find the command. Is this problem related to
> > my computer? or it is a general problem for nay operation systems?
> > NAMD tutorial should specify how these commands would work on the
> > other computers, ie Mac. And it would be much easier for people like
> > me as a new user of NAMD.
> >
> > All the best
> >
> > Bo
> >
>
>
>
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:19:04 CST