Re: namdplot: command not found

From: bo baker (bo.bybaker_at_gmail.com)
Date: Thu Oct 13 2005 - 14:26:47 CDT

Hello,

Thanks for your suggestions. But I am still stucked. The commands
didn't work. Here is how I did:

[mriv209-01:~] bo% cd desktop
[mriv209-01:~/desktop] bo% chmod a+x namdplot
[mriv209-01:~/desktop] bo% /Users/bo/Desktop/namdplot TEMP pbr1.log
tcsh: /Users/bo/Desktop/namdplot: Command not found.

Then I try 'chmod 755':

[mriv209-01:~/desktop] bo% chmod 755 namdplot
[mriv209-01:~/desktop] bo% /Users/bo/Desktop/namdplot TEMP pbr1.log
tcsh: /Users/bo/Desktop/namdplot: Command not found.

The computer just can't find the command. Is this problem related to
my computer? or it is a general problem for nay operation systems?
NAMD tutorial should specify how these commands would work on the
other computers, ie Mac. And it would be much easier for people like
me as a new user of NAMD.

All the best

Bo

On 10/12/05, Robert Brunner <rbrunner_at_uiuc.edu> wrote:
> You need to make namdplot executable before it will run. Type this
> once in the namdplot directory:
>
> chmod a+x namdplot
>
> then you should be able to run ./namdplot
>
> Robert
>
> On Oct 12, 2005, at 3:27 PM, bo baker wrote:
>
> > Hi, Thanks for your suggestion.
> >
> > I try the command from my account as well as the 'adm' account. But I
> > got the message saying that 'namplot: permission denied'. Here is how
> > I did:
> >
> > ----
> > [mriv209-01:~/desktop] bo% cd desktop
> > [mriv209-01:~/desktop] bo% ./namdplot
> > tcsh: ./namdplot: Permission denied.
> > ----
> >
> > Then I try the admister account:
> > ----
> > adm% /Applications/NAMD_2.6b1_MacOSX-PPC/namdplot TEMP pbr1.log
> > tcsh: /Applications/NAMD_2.6b1_MacOSX-PPC/namdplot: Permission denied.
> > ----
> >
> > Do I do something wrong? Thank you for your advice.
> >
> > Bo
> >
> > On 10/11/05, Robert Brunner <rbrunner_at_uiuc.edu> wrote:
> >
> >> You need to tell the OS where namdplot is, since its not it one of
> >> the directories it normally searches. Use "./namdplot" instead of
> >> "namdplot" so that it know to find namdplot in the current directory.
> >>
> >> Robert
> >>
> >> On Oct 11, 2005, at 6:56 PM, bo baker wrote:
> >>
> >>
> >>> Hello:
> >>>
> >>> Thank you very much for your suggestions. Yes, I use Mac OS X. I
> >>> downloaded the 'namdplot' script from the NAMD/utilities. And I have
> >>> the .log file in the same directory. Then I try to call 'namdplot
> >>> TEMP pbr1.log' as the tutorial suggested. But the computer can't
> >>> recognize 'namdplot' command. I guess that some commands need to be
> >>> added before 'namdplot'. Here is how I did:
> >>>
> >>> [mriv209-01:~/desktop] bo% namdplot
> >>> tcsh: namdplot: Command not found.
> >>> [mriv209-01:~/desktop] bo% namdplot TEMP pdr1.log
> >>> tcsh: namdplot: Command not found.
> >>>
> >>> I don't have experience to wrtie a program in unix. Can anyone
> >>> suggest
> >>> me how to modify the 'namdplot' script , so I can use it for the
> >>> Mac?
> >>> I don't have 'xmgrace' in the computer. I would like to write it
> >>> into
> >>> text file. So I can convert the data with other graph program later.
> >>>
> >>> I have included the 'namdplot' script as an attachment. Your help
> >>> will
> >>> be very appreciated.
> >>>
> >>> Bo
> >>>
> >>>
> >
>
>
>
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:19:04 CST