Re: errno = 2

From: bo baker (bo.bybaker_at_gmail.com)
Date: Wed Aug 17 2005 - 20:09:43 CDT

Hello,

Thanks all of you for being help me on this installation problem.

I tried the way as Jerry suggested. I install the 'vacpp' under my
home directory (i.e: /Users/bo), and the 'namd2' is in the directory
of ' /Users/bo/MD/NAMD/NAMD_2.6b1_MacOSX-PPC'. Then add the path to
where namd2. Here is how I did:

----
[mriv209-01:~] bo% setenv
DYLD_LIBRARY_PATH$DYLD_LIBRARY_PATH\:/Users/bo/MD/NAMD/NAMD_2.6b1_MacOSX-PPC/
----
But I got the message saying;
---
tcsh: DYLD_LIBRARY_PATH: Undefined variable
----
I am not good at the unix system, and confused on how to define the
DYLD. Do I do something wrong? Can you help me to fix this probelm? 
According to vaccp instruction, one needs to deinstall any XL C++ beta
or evaluation run-time packages before installing this run-time
environment.  And I don't know how do this. Does this cause the above
errors, or just I didn't set the path in the right way?
Your advices will be very appreciated.
Bo
On 8/17/05, Jerry Ebalunode <jebalunode_at_uh.edu> wrote:
> If you have root privileges, place the runtime library called
> "libibmc++.A.dylib" where namd2 expects to find it i.e.
> "/opt/ibmcmp/lib/libibmc++.A.dylib"
> 
> Otherwise add the path where you installed your namd2 to DYLD_LIBRARY_PATH
> variable
> 
> i.e. assuming your home directory is /Users/baker and you installed
> namd2.6b1 in /Users/baker/bin; to set the dylib path to see your
> libibmc++.A.dylib present in /Users/baker/bin
> 
> For bash shell run
> export DYLD_LIBRARY_PATH=$DYLD_LIBRARY_PATH:/Users/baker/bin
> 
> For csh/tcsh shell run
> setenv DYLD_LIBRARY_PATH $DYLD_LIBRARY_PATH\:/Users/baker/bin
> 
> 
> -----Original Message-----
> From: owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] On Behalf
> Of bo baker
> Sent: Wednesday, August 17, 2005 12:30 PM
> To: namd-l_at_ks.uiuc.edu
> Subject: Re: namd-l: errno = 2
> 
> Hello, NAMD:
> 
>  I install the NAMD_2.6b1 into a Mac computer (Mac OSX 10.3.9).  And I
> downloaded the runtime library into the same directory as 'namd2' I
> try
> to run 'namd2'.  Here is what  I got:
> 
> ------
> 
> [mriv209-01:~/MD/NAMD/NAMD_2.6b1_MacOSX-PPC] bo%
>  /Users/bo/MD/NAMD/NAMD_2.6b1_MacOSX-PPC/namd2 ubq_wb_eq.conf >
> unq_wb_eq.log
> 
> dyld: /Users/bo/MD/NAMD/NAMD_2.6b1_MacOSX-PPC/namd2 can't open
> library: /opt/ibmcmp/lib/libibmc++.A.dylib  (No such file or
> directory, errno = 2)
> Trace/BPT trap
> 
>  ------
> 
> The 'ubq_wb_eq.conf'  is from 'namd-tutorial-files' downloaded from
>  NAMD website. I have the 'ubq_wb.pdb' and 'ubq_wb.psf'  files at the
>  same directory. The runtime library is shown as 'opt' and in the same
> directory as others.  It seems that I don't have the NAMD installed
> properly. The computer is in mutiple users, and I am not the
>  adminstrator.
> 
> Thanks for any comments to fix this problem.
> 
>  Bo
> 
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:18:58 CST