Re: clustermatic 4 and 5 Namd/charm

From: Gengbin Zheng (gzheng_at_ks.uiuc.edu)
Date: Sat Jan 01 2005 - 15:15:45 CST

Hi Rene,

Good to hear Charm++ and NAMD runs on opteron with clustermatic 5.

For fftw support, you need to download fftw version 2 instead of version
3 in order to compile NAMD.
And you need to compile tcl in its static form (.a) instead of shared
lib for NAMD.
For detailed instruction on how to configure and compile it, please see
my NAMD wiki at
http://www.ks.uiuc.edu/Research/namd/wiki/index.cgi?NamdCompile

Alternatively, I think there are binaries on NAMD website you can
download for the fftw and tcl precompiled for opteron.

Gengbin

Rene Salmon wrote:

>
>
> Hi,
>
> The problem with charm was indeed the missing libs on the slave nodes.
> After I added the missing libs the charm tests worked fine.
>
> Next I moved to compile NAMD. I just followed your instructions and
> copied the "Linux-i686-Clustermatic.arch" to
> "Linux-amd64-Clustermatic.arch" here is what the file looks like:
>
> NAMD_2.5_Source/arch# cat Linux-amd64-Clustermatic.arch
> include .rootdir/arch/Linux-amd64-g++.arch
>
> CHARMARCH = net-linux-amd64-clustermatic
>
>
> --------
> here is what Linux-amd64-g++.arch looks like:
>
> NAMD_2.5_Source/arch# cat Linux-amd64-g++.arch
> NAMD_ARCH = Linux-amd64
> CHARMARCH = net-linux-amd64-clustermatic
>
> CXX = g++ -DSOCKLEN_T=socklen_t -DNO_STRSTREAM_H
> CXXOPTS = -O3 -fexpensive-optimizations -ffast-math
> CC = gcc
> COPTS = -O3 -fexpensive-optimizations -ffast-math
>
>
>
> -----------------------
>
> Next I tried to configure and compile:
>
> NAMD_2.5_Source/arch# ./config Linux-amd64-Clustermatic
>
> this worked and generated the NAMD executables with out any errors.
> I ran this test on NAMD:
>
> ./charmrun ++skipmaster ++verbose ++startpe 0 +p2 ./namd2 /tmp/alanin
>
> WRITING EXTENDED SYSTEM TO OUTPUT FILE AT STEP 9
> WRITING COORDINATES TO OUTPUT FILE AT STEP 9
> WRITING VELOCITIES TO OUTPUT FILE AT STEP 9
> ==========================================
> WallClock: 1.611247 CPUTime: 1.201816 Memory: 8895 kB
> Charmrun> Graceful exit.
>
>
> It seems to be working fine. Thank you very much for getting me this
> far.
>
>
>
>
> ----------------------
> I would like to have the fftw libs with NAMD so I tried this:
>
> NAMD_2.5_Source/arch# ./config tcl fftw Linux-amd64-Clustermatic
>
> If I add the fftw or tcl or both I get error messages and I do not get
> a NAMD binary.
>
> I installed fftw-3.0.1 from the fftw website with out any problems and
> just pointed the Linux-amd64.fftw to the fftw install.
>
> I also have tcl-8.4 installed on the system and I edited the
> Linux-amd64.tcl file to reflect the location of the libs and include
> files for tcl.
>
>
> Is there anything special I need to do to get NAMD to compile with
> fftw support? I checked the NAMD www site for precompiled libraries
> for both tcl and fftw for amd64 but found nothing. Anyone have these
> libs precompiled to work with NAMD?
>
> Thank you very much for all the help
>
> Rene
>
>
>
>
>
>
>
>
>
>

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:18:32 CST