AW: installing namd on ibm cluster (powerpc)

From: Norman Geist (norman.geist_at_uni-greifswald.de)
Date: Mon Dec 05 2011 - 03:30:48 CST

Hi,

well here we have the problem. You are running a linux os and try to execute
a AIX binary. Try a simple linux 64 bit binary like :
http://www.ks.uiuc.edu/Development/Download/download.cgi?UserID=&AccessCode=
&ArchiveID=1155

This is the Linux-64-udp version which is very fast on gigabit.

Have fun

Norman Geist.

> -----Ursprüngliche Nachricht-----
> Von: Gurunath Katagi [mailto:gurukatagi_at_gmail.com]
> Gesendet: Montag, 5. Dezember 2011 08:34
> An: Norman Geist
> Betreff: Re: namd-l: installing namd on ibm cluster (powerpc)
>
> HI ,,
>
> $uname -a
> Linux cnode39 2.6.5-7.244-pseries64 #1 SMP Mon Dec 12 18:32:25 UTC
> 2005 ppc64 ppc64 ppc64 GNU/Linux
> This is ibm power cluster with linux operating system ...
>
> hardware :
> Sixtyfour 4-way SMP nodes (256 processors) P720 open power
> systems
> IBM Power-5 processors operating at 1.65 GHz
> 4 GB main memory per node with a total of 256GB for the cluster
> 146GB Disk per node with a total of more 9TB disk space
> Dual Gigabit network with Nortel 5510 Gigabit switches
>
> SYSTEM SOFTWARE/LIBRARIES:
> SUSE Enterprise linux 9.0 Operating System
> XL FORTRAN 77 90 C Compilers with Debuggers.
> Support for IBM Symmetric Multiprocessor Open Shared Memory
> Parallelization Directives.
> Math Library ESSL
> Mathematical Acceleration Library MASS
> MPI Message Passing Directives.
> Batch Submission System - LoadLeveler
>
> in the NAMD download website, in the precompiled binaries for AIX
> machine, within paranthesis its given IBM power cluster, i assumed
> that IBM power pC that we have is same as AIX..which is not . kindly
> excuse me for the mistake ..
>
> Kindly let me know ..
>
> regards,
> Gurunath
>
>
>
> On 12/5/11, Norman Geist <norman.geist_at_uni-greifswald.de> wrote:
> > The script cannot be the problem at this point because its already
> tried to
> > execute the namd binary. Are you sure that you have AIX machines??
> Please
> > tell me what hardware/machines you have and what operating system you
> are
> > running, I think you just have a wrong binary ;) because the message
> comes
> > from your shell and tell you that it cannot execute this binary,
> surely
> > because it’s a wrong one. Just tell me what machines you have, and we
> see
> > then ;)
> >
> >
> >
> > Good luck
> >
> > Norman Geist.
> >
> >
> >
> > Von: Gurunath Katagi [mailto:gurukatagi_at_gmail.com]
> > Gesendet: Freitag, 2. Dezember 2011 17:03
> > An: Norman Geist
> > Betreff: Re: namd-l: installing namd on ibm cluster (powerpc)
> >
> >
> >
> > Hello sir,
> > as u said , i am trying with precompiled version,
> > but when i try to run the job, i as getting the following error in
> the error
> > file :
> >
> > ATTENTION: 0031-408 4 tasks allocated by LoadLeveler, continuing...
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > cannot execute binary file
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > cannot execute binary file
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > cannot execute binary file
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2:
> > cannot execute binary file
> >
> > and the out file gives the message like :
> > Running> poe
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2
> > md1.conf -nodes 16 -tasks_per_node 4 -rmpool 1
> >
> > which seems ok ...
> >
> > my submission script goes like the following:
> >
> > #!/bin/sh
> > # @ error = job1.$(Host).$(Cluster).$(Process).err
> > # @ output = job1.$(Host).$(Cluster).$(Process).out
> > # @ class = ptask64
> > # @ job_type = parallel
> > # @ total_tasks = 4
> > # @ blocking = unlimited
> > # @ wall_clock_limit=01:00:00
> > # @ queue
> > /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/charmrun
> > +p64 /home/staff/sec/secdpal/gurunath/namd-sp2/NAMD_2.7_AIX-POWER-
> MPI/namd2
> > 'md1.conf'
> >
> > Can u please tell me any modification to this script, so that it runs
> > successfully ...
> > or let me how do u run ..
> >
> > and the kind of network that we have is "Dual Gigabit network with
> Nortel
> > 5510 Gigabit switches"
> >
> > Thank you
> > Gurunath
> >
> >
> >
> >
> > On Thu, Dec 1, 2011 at 7:20 PM, Norman Geist
> > <norman.geist_at_uni-greifswald.de> wrote:
> >
> > Hi,
> >
> >
> >
> > another question just for my interest. Why do you want to compile
> namd
> > yourself? The precompiled versions from namd homepage work nice. What
> kind
> > of network do you have?
> >
> >
> >
> > regards
> >
> >
> >
> > Norman Geist.
> >
> >
> >
> > Von: Gurunath Katagi [mailto:gurukatagi_at_gmail.com]
> >
> > Gesendet: Donnerstag, 1. Dezember 2011 13:38
> >
> > An: Norman Geist
> > Betreff: Re: namd-l: installing namd on ibm cluster (powerpc)
> >
> >
> >
> > Dear sir ..
> >
> > sorry for late response ..
> > still it complains the same thing about C++ compiler not working ..
> > it is possible for u come one gmail chat sometimes, so that i can do
> it more
> > thoroughly ..
> >
> > Thank you
> > Gurunath
> >
> > On Tue, Nov 1, 2011 at 11:54 AM, Norman Geist
> > <norman.geist_at_uni-greifswald.de> wrote:
> >
> > Hi,
> >
> >
> >
> > charm++ is a objective parallel framework which has ist own mpi
> > implementation. If you don’t want to use these internals, you can
> build
> > charmrun on top of your own mpi. So you must have an mpi installed,
> like
> > openmpi for example. Then these mpi installation will have a C
> wrapper
> > compiler mpicc. This is only a wrapper and will call another C
> compiler (the
> > one you build this mpi with) with the right options and files needed
> for an
> > working mpi executable. In openmpi you can change the compiler which
> will be
> > called by the wrappers with the environment variables OMPI_MPICC
> OMPI_MPIF90
> > etc.
> >
> > Also if you want that mpi you must have the wrappers in your PATH
> > environment variable so that
> >
> >
> >
> > MPICC=mpicc can be looked up to MPICC=/absolute/path/to/mpicc #
> >
> >
> >
> > This is done with
> >
> >
> >
> > export PATH=$PATH:/my/path/to/mpi
> >
> >
> >
> > And check with
> >
> >
> >
> > which mpicc
> >
> >
> >
> > This should pouint to the right wrapper then.
> >
> >
> >
> > If you do not want to have an own mpi, which is not really needed,
> just use
> > a precompiled binary of namd or build charm with the internals, this
> has the
> > best performance especially on gigabit because it can run on udp
> while it
> > has its own checking built in.
> >
> >
> >
> > Feel free to ask ;)
> >
> >
> >
> > Norman Geist.
> >
> >
> >
> > Von: Gurunath Katagi [mailto:gurukatagi_at_gmail.com]
> > Gesendet: Montag, 31. Oktober 2011 07:59
> > An: Norman Geist
> > Betreff: Re: namd-l: installing namd on ibm cluster (powerpc)
> >
> >
> >
> > hi ..
> > could u please elaborate ..
> >
> > because, when i try to build, it asks us that ' u have mpicc enabled
> on ur
> > path, do u want to build charm++ on this MPI' ..
> >
> > and one more thing is..
> > if u compile without mpi, how to runt the jobs using poe ..?
> >
> > Thank u
> > Gurunath
> >
> > On Sat, Oct 29, 2011 at 11:23 PM, Norman Geist
> > <norman.geist_at_uni-greifswald.de> wrote:
> >
> > If you do not have mpi, dont use it, use the charm++ internal
> >
> >
> >
> > Mit freundlichen Grüßen
> >
> >
> >
> > Norman Geist.
> >
> >
> >
> > Von: owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] Im
> Auftrag
> > von Gurunath Katagi
> > Gesendet: Freitag, 28. Oktober 2011 22:14
> > An: namd-l_at_ks.uiuc.edu
> > Betreff: namd-l: installing namd on ibm cluster (powerpc)
> >
> >
> >
> > Dear all,
> > I was trying to install NAMD 2.8 version on IBM clsuter from source
> code
> >
> > $uname -a
> > Linux cnode39 2.6.5-7.244-pseries64 #1 SMP Mon Dec 12 18:32:25 UTC
> 2005
> > ppc64 ppc64 ppc64 GNU/Linux
> >
> > when i try to build the charm++ using the command ,
> > $env MPICXX=mpicc ./build charm++ mpi-linux-ppc mpicc --no-build-
> shared
> > --with-production
> >
> > it gives the error saying mpicxx compiler doesnt work and i have
> tried with
> > mpicc also, its giving the error .. i have pasted part of the output
> ..
> >
> > configure: WARNING: unrecognized options: --with-productio
> > Setting load balancing timer type as 'double'
> > checking machine name... mpi-linux-ppc
> > checking "cp command as"... cp -p
> > checking "C++ compiler as"... "mpicxx "
> > checking "whether C++ compiler works"... "no"
> > Cannot compile C++ programs with mpicxx
> > (check your charm++ version)
> > -----------..................
> >
> > Can anybody suggest compilers and other things need to be taken care
> of
> > during installation on this machine ..
> > or is there a precompiled vaersion of NAMD avaibale for this ibm
> cluster( i
> > have tried using AIX-power-lapi, but doesn't seem to work ) ..?
> >
> > Thank u
> > Gurunath
> >
> >
> >
> >
> >
> >
> >
> >

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:24:35 CST