RE: Resend - ERROR: Atoms moving too fast;

From: Nikhil Kumar Mittal (nikhil_at_hpclinks.com)
Date: Fri Nov 11 2011 - 20:02:51 CST

Again the message is cut-off (what's happening ?) :-(

-----Original Message-----
From: Nikhil Kumar Mittal [mailto:nikhil_at_hpclinks.com]
Sent: 12 November 2011 07:27 AM
To: 'namd-l_at_ks.uiuc.edu'
Subject: Resend - ERROR: Atoms moving too fast;

Resending .... (the message was cut-off for unknown reason),

-----Original Message-----
From: Nikhil Kumar Mittal [mailto:nikhil_at_hpclinks.com]
Sent: 11 November 2011 11:41 PM
To: 'namd-l_at_ks.uiuc.edu'
Subject: ERROR: Atoms moving too fast;

Hi,
I downloaded the NAMD 2.8 source code and built it on my CentOS 5.6 x86 64 bit
system with CUDA and OpenMPI enabled (I followed steps given in the notes.txt
and my build of namd2 ran fine without any problems).
I am using OpenMPI 1.4.3 and CUDA 4.0 (2 Tesla M2070 on one node).
When I run namd2 as a single process using stmv.namd it works fine. But as soon
as I increase the processes to 2 or more, I get following error:

>>>>>>>>>
ERROR: Atoms moving too fast; simulation has become unstable.
ERROR: Atom 1038654 velocity is 0.507241 3.10001e+10 -0.844506 (limit is 12000)
ERROR: Atoms moving too fast; simulation has become unstable.
ERROR: Atom 323772 velocity is 0.333522 -0.882513 1.7824e+06 (limit is 12000)
ERROR: Atoms moving too fast; simulation has become unstable.
ERROR: Atom 15012 velocity is 11184.3 262.211 20211.6 (limit is 12000)
ERROR: Atoms moving too fast; simulation has become unstable.
ERROR: Atom 532127 velocity is 2.05179 -3.58429 1.78385e+09 (limit is 12000)
ERROR: Atoms moving too fast; simulation has become unstable.
ETITLE: TS BOND ANGLE DIHED IMPRP
ELECT VDW BOUNDARY MISC KINETIC
TOTAL TEMP POTENTIAL TOTAL3 TEMPAVG
PRESSURE GPRESSURE VOLUME PRESSAVG GPRESSAVG

ENERGY: 0 354072.1600 280839.0161 81957.9556 4995.4407
-4503168.0835 384266.4616 0.0000 0.0000 -9999999999.9999
-9999999999.9999 -9999999999.9999 -3397037.0496 9999999999.9999
-9999999999.9999 -9999999999.9999 -9999999999.9999 10194598.5131
-9999999999.9999 -9999999999.9999

ERROR: Exiting prematurely; see error messages above.
====================================================

WallClock: 33.547344 CPUTime: 33.547344 Memory: 652.261719 MB
End of program
<<<<<<<<<<<<

I used following command:
mpirun -np 2 ./namd2 +idlepoll ../stmv/stmv.namd

The "stmv" simulation workload was downloaded from NAMD website (unchanged). The
help.original temperature is set to "298" which I have tried changing to low
values too (20). But that does not help as well.
What is that I could be doing wrong ?
Thanks,
Nikhil

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:24:32 CST