Re: "Constraint failure in RATTLE algorithm" when restart FEP

From: Dong Luo (us917_at_yahoo.com)
Date: Mon Aug 01 2011 - 10:50:27 CDT

While analyze the results, it turned out to be my fault for previous ERROR. For some reason, I wrongly read the log of first simulation and put wrong lambda start value in restart configuration. The lambda value is already 0.99, but I thought it to be 0.2, that explains all.
Sorry for my noise to the mailing list.

Dong

________________________________
From: Dong Luo <us917_at_yahoo.com>
To: namd-l list <namd-l_at_ks.uiuc.edu>
Sent: Friday, July 29, 2011 3:36 PM
Subject: Re: namd-l: "Constraint failure in RATTLE algorithm" when restart FEP

Re-minimize the system before restart worked around the problem. But I am not sure how the results will be affected by the reinitialization of atom speed.

Dong

________________________________
From: Dong Luo <us917_at_yahoo.com>
To: namd-l list <namd-l_at_ks.uiuc.edu>
Sent: Thursday, July 28, 2011 1:21 PM
Subject: namd-l: "Constraint failure in RATTLE algorithm" when restart FEP

The FEP simulation is on a mutation from TYR to ALA. The mutated residue is surround by other residues. Upon continue from restart files, the simulation immediately complained with "ERROR: Constraint failure in RATTLE algorithm for atom ####". Check the protein in VMD show that some of the TYR atoms are within 1 angstrom of atoms from surrounding residues. Is this normal as TYR is disappearing during the simulation? But how can a restart get over with that ERROR. It looks to me the simulation runs without problem before the restart point with the same situation. The configuration file for restart is following previous posts in this mailing list.

Dong

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:24:15 CST