RE: Lithium

From: Ahmet Bakan (abakan_at_ku.edu.tr)
Date: Thu Apr 29 2004 - 11:14:56 CDT

Hi Greg,

I guess that you do not have the following line in your NAMD config file.

paraTypeCharmm on

To make PSFGEN work, you need to give necessary topology file that
represents your system, defining bonded atoms, atom types etc.

On my site I have some manuals to develop topology and parameter files. It
will be easy to define a topology for a lithium atom since it does not make
any bonds.

Like this:
MASS 92 LI 6.49100 LI

RESI LIT 0.0 !Change the charge and atom
ATOM LI LI 0.0 !type the way you defined your parameters
PATCH FIRST NONE LAST NONE

You should have different residue numbers for each lithium atom. Then, you
will use PSFGEN with no problems.

I hope this helps you,
Ahmet

==========ABC==========
Ahmet Bakan
Chemistry, Junior
Koc University
abakan_at_ku.edu.tr
ICQ #86167698
http://home.ku.edu.tr/~abakan

-----Original Message-----
From: owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] On Behalf
Of Scott, Greg
Sent: Thursday, April 29, 2004 7:30 AM
To: namd-l_at_ks.uiuc.edu
Subject: RE: namd-l: Lithium

It was pointed out to me that I typed in the wrong file. I am, in fact,
using the par_all22_prot.inp file, not the topology file.

Thanks,
Greg

-----Original Message-----
From: owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] On
Behalf Of Scott, Greg
Sent: Wednesday, April 28, 2004 11:04 PM
To: namd-l_at_ks.uiuc.edu
Subject: namd-l: Lithium

I am new to NAMD and am trying to use it for a simple, non-protein
system. Basically, I'm looking at the solvation of lithium and have
determined an inner solvation sphere through ab initio computations and
want to solvate that further and run MD. I have two problems:
 
1) Building the psf file. I couldn't get psfgen to work, but using my
pdb file, I used VEGA to create a psf file and hacked around at it until
I made it look like I think it should after having read the
documentation. Perhaps I have done something wrong here, perhaps not.
 
2) A parameter for lithium. I have potential parameters for lithium
and tried to add them to the top_all22_prot.inp (which I have renamed
lith.param) file using the exact same format as is used for calcium in
the non-bonded interactions section.
 
When I try to run a simulation, I get the following:
 
FATAL ERROR: UNKNOWN PARAMETER IN XPLOR PARAMETER FILE lith.param
LINE=**>>>> CHARMM22 All-Hydrogen Parameter File for Proteins
<<<<<<<<<<*
Fatal error on PE 0> FATAL ERROR: UNKNOWN PARAMETER IN XPLOR PARAMETER
FILE lith.param
LINE=**>>>> CHARMM22 All-Hydrogen Parameter File for Proteins
<<<<<<<<<<*

I would appreciate any insight on the matter.
 
Thank you,
Greg Scott

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:18:12 CST