libc6 on debian x86

From: Grischa R. Meyer (grischa_at_graduates.uwa.edu.au)
Date: Thu Sep 11 2003 - 22:42:17 CDT

Hi,

I updated libc on our debian (sid) systems to version 2.3.2-6 and namd
doesn't run anymore, there are problems with libnss_compat, which was
changed in this version.

I was wondering if there will be binaries available that work with the
new library, or if I need to compile my own.

The error was as follows:
$ charmrun ++local /opt/bin/namd2.5b2
Info: NAMD 2.5b2 for Linux-i686
Info:
Info: Please visit http://www.ks.uiuc.edu/Research/namd/
Info: and send feedback or bug reports to namd_at_ks.uiuc.edu
Info:
Info: Please cite Kale et al., J. Comp. Phys. 151:283-312 (1999)
Info: in all publications reporting results obtained with NAMD.
Info:
Info: Built Wed Jun 11 22:12:20 CDT 2003 by justin on
aberdeen.ks.uiuc.edu
Info: Sending usage information to NAMD developers via UDP.
------------- Processor 0 Exiting: Caught Signal ------------
Signal: segmentation violation
Suggestion: Try running with '++debug', or linking with '-memory
paranoid'.
Stack Traceback:
  [0] [0x82c1348]
  [1] /lib/libc.so.6 [0x40143dce]
  [2] /lib/libc.so.6 [0x40143ee8]
  [3] __nss_lookup_function+0x1f9 [0x40123399]
  [4] /lib/libnss_compat.so.2 [0x4002136e]
  [5] _nss_compat_getpwuid_r+0xc5 [0x40022f05]
  [6] [0x82e3129]
  [7] [0x82e2cd7]
  [8] [0x804a2f7]
  [9] [0x804d590]
Fatal error on PE 0> segmentation violation

Thanks,

Grischa

-- 
Grischa R. Meyer, grischa_at_graduates.uwa.edu.au

This archive was generated by hypermail 2.1.6 : Wed Feb 29 2012 - 05:17:51 CST