
JMV User’s Guide

M. Bach, R. Brunner, J. Stone, K. Vandivort

Version 0.85

June 25, 2002

Theoretical Biophysics Group1

University of Illinois and Beckman Institute
405 N. Mathews
Urbana, IL 61801

JMV WWW home page: http://www.ks.uiuc.edu/Development/jmv/

Description

The JMV User’s Guide describes how to run and use the molecular visualization and analysis
program JMV. This guide documents the usage of the graphical user interface for displaying and
grapically manipulating molecules, and describes how to customize the appearance and behavior
of JMV for each user.
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Chapter 1

Introduction

JMV is a Java Molecular Viewer written in Java and Java3D. It can be used to load data files to
display molecules in common molecular representations and color styles. Users can load files from
a URL, from a local file, or from the RCSB databank. Users can also load PDB files when using
BioCoRE. JMV also provides display and lighting options, and support for stereoscopic viewing.
Java technology gives JMV platform independence, and allows it to run within a web browser or
as a standalone application. It also uses Java Beans, making it modular and customizable, so
developers can choose which components they wish to add. Since it can be used in webpages, it
is i deal for applications such as electronic textbooks, to replace static images with an interactive
tool. Online information on JMV is available at: http://www.ks.uiuc.edu/Development/jmv/.

List of key JMV features:

• General molecular visualization
JMV has the ability to read PDB files, and view the molecules in common representations
and color schemes.

• Applications
JMV can be run as an applet, as a standalone application, or within another application.

• VRML files
JMV can also read in VRML version 2.0 files. This makes it possible to view molecular
representations JMV cannot draw on its own, such as Cartoon, if the right VRML file can be
found. It also allows JMV to draw non-molecular data.

• Saving and loading states
Once you start JMV and load a molecule, and get it into a representation, color, and orien-
tation that you like, you can then save that state so that you can see that same view later,
or so others can see the same view. You also have the option of saving a jpeg of the JMV
screen.

• Interaction with BioCoRE
BioCoRE, the Biological Collaborative Research Environment, uses JMV. From within Bio-
CoRE, you can view PDB files, and save states and pictures to its own filesystem.
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1.1 Credits and Program Reference

The authors request that any published work or images created using JMV include the following
reference:

Bach, M., Brunner, R., Stone, J., Vandivort, K. “JMV”

JMV has been developed by the Theoretical Biophysics group at the University of Illinois and
the Beckman Institute. The main authors of JMV are M. Bach, R. Brunner, J. Stone, K. Vandivort.
This work is supported by grants from the National Institutes of Health (grant number PHS 5 P41
RR05969-04), the National Science Foundation (grant number BIR-9423827 EQ), and the Roy J.
Carver Charitable Trust.

1.2 Copyright and Disclaimer

JMV is Copyright c© 2000-2002 Theoretical Biophysics Group and the Board of Trustees of the
University of Illinois
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Chapter 2

Tutorials

2.1 Rapid Introduction to JMV

Here is a quick introduction to JMV. To start, you need Java and Java3D. See the Installation
Guide for more details on getting those. From there, you can view JMV in a browser simply by
visiting a webpage that uses JMV. Or, to run it as a standalone application, download and extract
the JMV applet from the main site (http://www.ks.uiuc.edu/Development/jmv/), go to the
directory you extracted it in, and start it with the command “java -classpath jmv-0.85.jar JMV”.
Here, “jmv-0.85.jar” may use a different number in place of “0.85” depending on the version.

2.2 Viewing a molecule: Titin

Once you have JMV started, you can load a molecule in a number of ways. Select “Load a file”
from the “File” menu. This will bring up a dialog box asking for a file name. Type in “1TIT”
and click “Load”. This will load the molecule Titin from the RCSB, a repository of molecular
files. The screen should display “Loading...” indicating that it is currently loading the molecule,
and then display it. You can move the molecule with the mouse buttons. The left button rotates
it, the middle button zooms, and the right button translates it. On 2-button mice, rotation is
accomplished by pressing the Alt-key and the left mouse button.
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Chapter 3

User Interface Components

Once you have JMV started, and have a file loaded, navigation is very simple. The molecule appears
in the main canvas and the controls appear below. The mouse controls to orient the molecule are:

Left button: Rotate
Middle button: Zoom (Moving the mouse down zooms in, moving it up zooms out)
Right button: Translate

On 2-button mice, the controls are:

Left button: Rotate
Left button + ALT: Zoom (Moving the mouse down zooms in, moving it up zooms out)
Right button: Translate
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Chapter 4

Loading A Molecule

The “Load a file” section under the “File” menu brings up the file selection dialog box that allows
you to load files to view in JMV. There are 2 types of files JMV can currently read, PDB files
and VRML files. PDB files end with the extension “.pdb” and VRML files end with the extension
“.wrl”.

You can use JMV to view local pdb files on your computer. If you are using JMV as an applet,
the jar files must be signed to access your files. Type in the full path to the file you wish to view,
or click on the “Browse” button, which will allow you to browse your system for files. When you
have selected one, click on the “Load” button, and your molecule should be displayed. If you get
an error, check that the file really does exist, that you have spelled the file’s name correctly, and
that it is a properly formatted file.

You can also load a PDB file from the web. Loading a file from the web is much like loading
a local file. Type the full URL of the pdb file you wish to view into the text field, and press the
“Load” button. The file should be displayed.

The Protein Data Bank is a repository for many pdb files. Each file stored there is identified
by a unique 4-digit code. If you know that code, you can load the molecule in JMV. Type in the
4-digit code in the text field in the dialog box that appears. Click the “Load” button and the
molecule will be displayed.

In addition to PDB files, JMV can also load VRML (Virtual Reality Markup Language) files.
VRML is a language that describes 3D scenes. You can view VRML files on the web by typing
the URL in the text field, or you can view local VRML files by typing in the full pathname of the
local file, or click on the “Browse” button and select it from the file-selection dialog. JMV can
only display VRML files that are version 2.0. These files start with the line: “#VRML V2.0 utf8”.
Version 1.0 files start with the line “#VRML V1.0 ascii” and cannot be displayed in JMV. In order
to view VRML files in an applet, the vrml97.jar must be in the ARCHIVE parameter in the html
code. In order to view VRML files using JMV as a standalone application, the vrml97.jar file must
be included in the classpath.
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Chapter 5

Molecular Drawing Methods

5.1 Molecular Drawing Methods

JMV allows you to view the molecule with different representations. To change the representa-
tion, select “Representation” from the “View” menu, and select one of the choices. The current
representations available are:

5.1.1 Lines

The default representation is ‘Lines’, which is also known as ‘wireframe’. It draws a line between
each atom and the atoms to which it is bonded. The first half of each bond is colored appropriately
for the first atom, while the color of the final half corresponds to the second atom.

5.1.2 Bonds

Nearly everything about this option is the same as lines except that instead of drawing a bond as
a line between two atoms, a cylinder is drawn instead.

5.1.3 CPK

CPK is a combination of “Bonds” and “VDW” in that it draws the atoms as spheres and also draws
the bonds connecting them. The sphere are drawn much smaller than in VDW, and the cylinders
are thinner than in Bonds. Each sphere is drawn with a radius that depends on the atom type.

5.1.4 VDW

VDW draws the atoms as spheres. Each sphere is drawn with a radius that depends on the atom
type.

5.1.5 Licorice

‘Licorice’ draws the atoms as spheres and the bonds as cylinders. The difference between this and
‘CPK’ is that the sphere radii are all the same, and are the same size as the bond.
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5.1.6 Tube

Tube draws a spline curve that goes through all the “Carbon-alpha” (CA) atoms in the molecule.
The spline curve is drawn as a series of cylinders.

5.1.7 Trace

Trace draws cylinders connecting the “Carbon-alpha” (CA) atoms in the molecule. This is similar
to Tube, except the atoms are directly connected by cylinders, not by a smooth spline.

5.2 Coloring Methods

JMV implements a variety of ways to color the molecule. To change the coloring method, select
“Color by” from the “View menu”, and select one of the choices. The choices are:

Style Description
Name Each atom type is assigned a different color. These colors are:

Carbon: Cyan
Hydrogen: White
Oxygen: Red
Nitrogen: Blue
Sulfur: Yellow
Phosphorus: Tan
Zinc: Silver
Other: Green

Index The pdb file assigns each atom a unique index identifier. In the Index color scheme, JMV
creates a color gradient that creates a smooth color transition going through each atom, in
order of their index numbers.

Resname In the pdb file, each atom belongs to a certain residue.The Resname color scheme assigns a
color to each Residue Name (based on the gradient), and colors each residue with the given
color.

Chain In the pdb file, each atom belongs to a certain Chain. The Chain color scheme assigns a
color to each Chain (based on the gradient), and colors each chain with the given color.

Segment In the pdb file, each atom belongs to a certain Segment. The Segment color scheme assigns
a color to each Segment (based on the gradient), and colors each segment with the given
color.

Structure Certain series of atoms may have a “structure” associated with them. If these structures
are written n the pdb file, JMV can color the molecule by structure. The structures and
their colors are:
No structure specified: White
Helix: Red
Turn: Green
Sheet: Blue
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Chapter 6

Molecule colors

JMV allows you to change the color gradient of the molecule. When selecting a color gradient, JMV
uses 3 colors, a beginning, middle, and end color. The gradient fades from the beginning to the
middle, and then from the middle to the end color to create a smooth color gradient. The number
of “in-between” colors for each gradient is determined by the number of items being colored. For
example, if the molecule is colored by index, then each atom gets its own color. If the molecule
is colored by residue, each residue type will get its own color. The representations “Name” and
“Structure” have their own color schemes, and are not affected by the color gradients.

To change the color gradient, select “Color Gradient” from the “View” menu and select one of
the choices. The current color gradients are:

Style Description
RGB Red→Green→Blue
BGR Blue→Green→Red
RWB Red→White→Blue
BWR Blue→White→Red
BW Black→White
WB White→Black
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Chapter 7

Saving and loading sessions

JMV allows you to save a session. Once you get a molecule in a particular representation, color,
and orientation that you like, you can then save that session so you can look at it again later, or
so that others can view your findings.

7.1 Saving a session

Once you have the molecule in a format that you would like to save, select the “Save session” option
under the “File” menu. Type in a name for the file, and click on the “Save to local disk” button to
save it, or “Cancel” to cancel. On Suns and Linux boxes, it will save the files in the directory you
started your browser, if you have permission to write files there. On Windows machines, it will save
the files in the default home directory. Saved JMV session end with the extension “.jmv”. This
file contains data about the current session of the JMV molecule, including the file, representation,
color, and orientation. You also have the option of saving a JPEG. If the “Save a JPEG of the
JMV image?” button is checked, a JPEG file will be saved with the same name as the .jmv file,
but with the extension “.jpg”. This is a picture of the JMV molecule window.

7.2 Loading a saved session

To load a saved session, select “Load session” from the “File” menu. From the pop-up window,
either type in the path to a .jmv file on your system, or select one from your local system with the
“Browse” button. Load the JMV file by clicking the “Load” button, or cancel with the “Cancel”
button. This will load the molecule with the representation, color, and orientation that it was saved
with. Please note that the file that the session saved must be a publicly accessable file, such as a
URL, if others wish to view it.

7.3 Loading and saving in BioCoRE

BioCoRE, (http://www.ks.uiuc.edu/Research/BioCoRE/), also uses JMV files. When in Bio-
CoRE, you can open a PDB file in the BioFs with JMV by clicking the “Properties” link on the
right side of the BioFs entry. From the window that is displayed, select the “View this molecule
in JMV” link. This will open the PDB file with JMV. To save a session to BioCoRE, select “Save
session to BioCoRE” from the “File” menu. This will save the session to the BioFs and to your
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local filesystem. If you selected the “Save a JPEG of the JMV image?” box, then a JPEG file of
the molecule window will also be saved to the BioFS and to your local filesystem. You can view
saved .jmv files in the same way as PDB files, by selecting the “Properties” link, and the “View
this molecule in JMV” link in the pop-up window that is displayed.
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Chapter 8

Viewing Modes

JMV allows you to view the molecule in stereoscopic view. In stereoscopic view, 2 molecules are
drawn, each from a slightly different viewpoint. These views are then switched back and forth very
rapidly. When viewed with special glasses, each image is given to one eye, and the image appears
in 3d. To view stereoscopic rendering, you need to set up your computer properly.

For instructions on how to set up your computer for viewing stereo with Java3d, please visit
j3d.org’s stereo FAQ at http://www.j3d.org/faq/stereo.html.

If you have stereoscopic viewing enables, you can turn it on by selecting the “Stereo” checkbox
under the “View” menu.

For Solaris:

1. At a command prompt, type:
afbconfig -proc
Look for the line saying “Current resolution setting” and write it down. You may want this
information if you change your stereo settings.

2. Type:
afbconfig -res stereo
This command puts your X server into stereo mode.

3. Log out of your current session and relog in. The resolution may be different.

4. In your Java Plug-In Control Panel, add the following option to the “Java Runtime Parame-
ters” field:
-Dj3d.stereo=PREFERRED

5. Start JMV. If you set Stereo to On, you should see a stereoscopic view of the molecule. If
you want to reset the resolution back to what it was before you changed it, type:
afbconfig -res resolution
where resolution is the resolution gotten from step 1.
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Chapter 9

Display options

The “Display Options” choice under the “View” menu brings up a panel allowing you to change
display settings in JMV.

• Lights:
The JMV scene has 4 built in lights: A light coming from the front, one from the back, one
from the top, and one from the bottom. The default setting is that the front light is on, and
all others are off. These lights may be turned on and off in the Display Options. The Display
Options panel displays 4 checkboxes, with labels “Upper light”, “Lower light”, “Front light”,
and “Back light”. If the checkbox in front of the label is checked, then the light in the scene is
on. Any combination of the lights may be selected. If all lights are off, the scene will appear
blank.

• Sphere resolution:
You can change the resolution of the spheres in JMV, making spheres appear smoother or
rougher. Decreasing the resolution of the spheres will make the scene move faster in rotation,
but will make the molecule look less sharp. Increasing the resolution of the spheres will make
the spheres appear smoother, but can make the molecule move more slowly. This setting only
affects representations that draw spheres, which currently are VDW, CPK, and Licorice. The
resolution has a minimum of 3 and a maximum of 30. The default is set to 8.

• Depth cueing:
JMV allows you to add depth cueing, which is a “fog” that makes objects in the distance
darker. This gives the scene a better sense of depth. Select the checkbox labelled “Depth
cueing” to activate depth cueing.
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